Bug 1461775 - incomplete isos in Rawhide composes
incomplete isos in Rawhide composes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PPCTracker
  Show dependency treegraph
 
Reported: 2017-06-15 06:10 EDT by Michel Normand
Modified: 2017-07-10 16:07 EDT (History)
6 users (show)

See Also:
Fixed In Version: lorax-27.3-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-10 16:07:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
slof_reports_not_bootable_device.log (3.59 KB, text/plain)
2017-06-15 06:10 EDT, Michel Normand
no flags Details

  None (edit)
Description Michel Normand 2017-06-15 06:10:54 EDT
Created attachment 1287976 [details]
slof_reports_not_bootable_device.log

Rawhide 20170614 ppc64le: "E3404: Not a bootable device!"

same problem with compose 20170613.
the last time I tried was compose 20170531 no such problem.

I specified grub2 as component for this bug, but not sure this is the right one.

Steps to Reproduce:
1. retrieve last DVD from https://kojipkgs.fedoraproject.org/compose/rawhide/latest-Fedora-Rawhide/compose/Server/ppc64le/iso/
2. try to install on a qemu guest.
3. slof is reporting specified error
   (details of slof console in attached slof_reports_not_bootable_device.log)
Comment 1 Michel Normand 2017-06-15 06:25:44 EDT
the checksum after iso download do match the one specified on repo.
Comment 2 Michel Normand 2017-06-15 06:32:08 EDT
most probably an iso build problem as missing boot dir in mounted iso:

===
$mount -o loop,ro -t iso9660 Fedora-Server-dvd-ppc64-Rawhide-20170614.n.0.iso /tmp/mnt
===
#ls -a /tmp/mnt/
.  ..  .discinfo  drpms  media.repo  Packages  repodata  TRANS.TBL  .treeinfo
===
Comment 3 Dan Horák 2017-06-15 07:04:23 EDT
Then some of the tools in the compose process failed to do its work. Some more info could be in https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20170614.n.0/logs/ppc64/
Comment 4 Sinny Kumari 2017-06-15 09:30:57 EDT
Even ppc64le Rawhide iso has similar issue.
$ mount -o loop,ro -t iso9660 Fedora-Server-dvd-ppc64le-Rawhide-20170614.n.0.iso /tmp/ppc64le/

$ ls -a /tmp/ppc64le/
.  ..  .discinfo  drpms  media.repo  Packages  repodata  TRANS.TBL  .treeinfo

boot and ppc directories are missing.
Comment 6 Brian Lane 2017-06-15 15:11:15 EDT
/usr/sbin/lp_diag wants one of the ncurses library files that are removed by runtime-cleanup.

2017-06-14 07:51:15,407: libmenu.so.6, needed by /usr/sbin/lp_diag, not found

I'm having a hard time figuring out what provides lp_diag. Either it needs to be removed, or the ncurses libraries need to be restored.
Comment 7 Brian Lane 2017-06-15 15:19:46 EDT
Found it ppc64-diag - https://koji.fedoraproject.org/koji/buildinfo?buildID=853400

Last rebuilt in 2/17 though, so why is this just showing up now? If lp_diag is something that would be useful to have in the installer environment (possibly for debugging problems?) then I'm ok with restoring libmenu. But I don't use ppc64 so need some input from those that do.
Comment 8 Sinny Kumari 2017-06-16 01:48:18 EDT
(In reply to Brian Lane from comment #7)
> Found it ppc64-diag -
> https://koji.fedoraproject.org/koji/buildinfo?buildID=853400
> 
> Last rebuilt in 2/17 though, so why is this just showing up now? If lp_diag
> is something that would be useful to have in the installer environment
> (possibly for debugging problems?) then I'm ok with restoring libmenu. But I
> don't use ppc64 so need some input from those that do.

I believe this is showing up now because request to add ppc64-diag as default in Fedora for ppc64(le) arches happened recently https://bugzilla.redhat.com/show_bug.cgi?id=1433859#c8 . From Changelog entry of lorax package (Add ppc64-diag for Power64 platforms), related changes landed in F27 with build lorax-27.0-1.fc27 (https://koji.fedoraproject.org/koji/buildinfo?buildID=899147) which happened on 30th May.
Comment 9 Sinny Kumari 2017-06-19 05:18:23 EDT
Have sent upstream a pull request in lorax which should fix this bug. PR link - https://github.com/rhinstaller/lorax/pull/218 .
Comment 10 Sinny Kumari 2017-06-20 01:57:44 EDT
Thanks Brian for quick review!
Any idea when lorax-27.3-1 build will be available in Fedora rawhide?
Comment 11 Sinny Kumari 2017-06-22 08:27:15 EDT
Rawhide nightly compose from 20170621.n.0 looks to be using lorax-27.3-1 (which contains fixes). Compose link is https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20170621.n.0/compose/Server/ .

Compose log seems complete to me with no further issue (e.g. ppc64 log - https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20170621.n.0/logs/ppc64/buildinstall-Server.ppc64.log ). ISO boots fine to me.

Note: Anaconda fails to start though which should be a separate issue, reported in RHBZ#1463960

Note You need to log in before you can comment on or make changes to this bug.