Bug 1461800 - Metrics numeric value for records with only one value are reported as array and not a number
Metrics numeric value for records with only one value are reported as array a...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rubygem-fluent-plugin-collectd-nest (Show other bugs)
4.1.2
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-4.1.3
: ---
Assigned To: Shirly Radco
Lukas Svaty
: Rebase, ZStream
Depends On:
Blocks: oVirt-Metrics-and-Logs 1455608
  Show dependency treegraph
 
Reported: 2017-06-15 07:03 EDT by Shirly Radco
Modified: 2017-07-06 03:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 03:31:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Metrics
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github ViaQ/fluent-plugin-collectd-nest/pull/7 None None None 2017-06-15 07:08 EDT

  None (edit)
Description Shirly Radco 2017-06-15 07:03:56 EDT
Description of problem:
Metrics numeric value for records with only one value are reported as array and not as a number.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Set up metrics store.
2. Set up metrics on the hosts and engine.
3. Search for the value of plugin such as cpu, memory and see that is reported as a number.

Actual results:
field is reported as an array.

Expected results:
field is reported as a number.

Additional info:
Comment 2 Sandro Bonazzola 2017-06-15 11:22:19 EDT
Need a rebase on 0.1.4
Comment 4 Lukas Svaty 2017-06-20 06:03:27 EDT
tested on memory and cpu, both values reported as numbers

ovirt-engine-metrics-1.0.4.2-1.el7ev.noarch
Comment 6 errata-xmlrpc 2017-07-06 03:31:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1693

Note You need to log in before you can comment on or make changes to this bug.