Bug 1461818 - Gnome core dumps on startup with llvmpipe crash due to llvm failing to clear high 16bits of correct register [RHEL-7.5]
Gnome core dumps on startup with llvmpipe crash due to llvm failing to clear ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: llvm-private (Show other bugs)
7.4-Alt
aarch64 Unspecified
unspecified Severity unspecified
: rc
: 7.5
Assigned To: Tom Stellard
qe-baseos-tools
:
Depends On: 1486998 1500113
Blocks: 1471969 1485496
  Show dependency treegraph
 
Reported: 2017-06-15 07:47 EDT by Laszlo Ersek
Modified: 2018-04-10 12:19 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of: 1429050
Environment:
Last Closed: 2018-04-10 12:19:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0894 None None None 2018-04-10 12:19 EDT

  None (edit)
Description Laszlo Ersek 2017-06-15 07:47:42 EDT
+++ This bug was initially created as a clone of Bug #1429050 +++

The exact same issue as described in bug 1429050 happens in RHEL-7.4 as well, using package "mesa-private-llvm-3.9.1-3.el7.aarch64".

Jeremy's patch in bug 1429050 comment 4 (direct link: attachment 1261680 [details]) applies to the above-mentioned RHEL-7.4 package (i.e., dist-git commit 6ec0b20b46c9) without conflicts, and works fine:

http://people.redhat.com/lersek/a95d492b-9f7a-4ba5-a6a4-a030f66bcae8-pegas10-aarch64-gnome.png

For RHEL-Alt-7.4, sibling bug 1461815 has been filed. For RHEL-7.5, please incorporate the patch normally.
Comment 2 Igor Gnatenko 2017-06-15 08:20:27 EDT
Please, can you create new bugs instead of cloning them? Me (and probably all others who were CCed on original bug) don't want to see RHEL-related bugs.
Comment 13 Miloš Prchlík 2018-01-22 08:23:55 EST
The fix seems to be included in the sources, AFAICT after digging a bit into llvm srpm. I ran tests included in mesa-17.0.1-6.20170307.el7.src.rpm, no segfaults appeared. Switching to VERIFIED.
Comment 14 Miloš Prchlík 2018-01-22 08:24:44 EST
Oh, and the llvm build tested was llvm-private-5.0.0-3.el7.
Comment 17 errata-xmlrpc 2018-04-10 12:19:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0894

Note You need to log in before you can comment on or make changes to this bug.