Bug 1461820 - lsmcli fs-export -h lists cmd arguments in incorrect way => lsmcli: error: please specify --ro-host or --rw-host
lsmcli fs-export -h lists cmd arguments in incorrect way => lsmcli: error: p...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Gris Ge
Jakub Krysl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 07:51 EDT by Jakub Krysl
Modified: 2018-04-10 11:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: libstoragemgmt-1.6.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 11:36:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of incorrect cmd help leading to error (149.80 KB, image/png)
2017-06-15 07:51 EDT, Jakub Krysl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0864 None None None 2018-04-10 11:36 EDT

  None (edit)
Description Jakub Krysl 2017-06-15 07:51:54 EDT
Created attachment 1288041 [details]
Screenshot of incorrect cmd help leading to error

Description of problem:
Using command "lsmcli fs-export -h" gives wrong help by listing only "--fs <FS_ID>" in required arguments while either of "--ro-host" or "--rw-host" is required too, not optional as listed.
Following the help and using only --fs leads to error:
lsmcli: error:  please specify --ro-host or --rw-host

Version-Release number of selected component (if applicable):
libstoragemgmt-1.4.0-3.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. create new volume (lsmcli fs-create --name <FS_NAME> --size <SIZE> --pool <POOL_ID>)
2. get ID of the volume (lsmcli list --type FS)
3. try to export that volume following command help using only listed required arguments (lsmcli fs-export --fs <FS_ID>)

Actual results:
Help message is incorrect, following it leads to error.

Expected results:
Correct help message that does not lead to error.

Additional info:
Comment 3 Gris Ge 2017-10-17 11:52:51 EDT
Patch has been send to upstream:
https://github.com/libstorage/libstoragemgmt/pull/314
Comment 5 Jakub Krysl 2017-10-20 05:29:14 EDT
Although it --ro-host and --rw-host are still in optional, they now say at least on of these is required, which should be clear enough:

  --ro-host <RO_HOST>   The host/IP has readonly access.                                                 
                        This is repeatable argument.                                                     
                        At least one '--ro-host' or '--rw-host' is required.                             
  --rw-host <RW_HOST>   The host/IP has readwrite access.                                                
                        This is repeatable argument.                                                     
                        At least one '--ro-host' or '--rw-host' is required.
Comment 8 errata-xmlrpc 2018-04-10 11:36:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0864

Note You need to log in before you can comment on or make changes to this bug.