Bug 146183 - [RHEL3U4] chicony usb keyboard fails, with side effects
[RHEL3U4] chicony usb keyboard fails, with side effects
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 15:23 EST by Stuart Hayes
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:08:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add this keyboard to the blacklist with "noget" quirk (907 bytes, patch)
2005-01-25 15:25 EST, Stuart Hayes
no flags Details | Diff
A cleaned version suitable for application (1.14 KB, patch)
2005-03-21 18:55 EST, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Stuart Hayes 2005-01-25 15:23:53 EST
Description of problem:

We have a Dell Chicony USB keyboard (model KU-9985) which fails to 
work when plugged in.  There are ugly messages in /var/log/messages, 
and "lsusb" will hang.

It turns out that this keyboard says that it has both a keyboard and 
a mouse, though there really is no mouse at all (no PS/2 port, no 
mouse).  When Linux issues a "get_report" for the mouse reports, the 
keyboard stalls, and things go downhill.

This keyboard works fine if we add it to the blacklist with 
the "NOGET" quirk.

Version-Release number of selected component (if applicable):


How reproducible:
Very easy.

Steps to Reproduce:
1. Boot up system.
2. Plug in KU-9985 Chicony usb hub keyboard.
3. 
  
Actual results:
Keyboard doesn't work, there are ugly messages, and "lsusb" will hang.

Expected results:
Keyboard should work, lsusb should work normally.

Additional info:
I will attach the patch.
Comment 1 Stuart Hayes 2005-01-25 15:25:15 EST
Created attachment 110212 [details]
patch to add this keyboard to the blacklist with "noget" quirk
Comment 2 Pete Zaitcev 2005-03-21 18:55:50 EST
Created attachment 112198 [details]
A cleaned version suitable for application

Stuart forgot to diff for patch -p1 and also swapped arguments. Tsk tsk :-)
This ought to work a little better.
Comment 3 Stuart Hayes 2005-03-22 11:15:20 EST
How embarrassing!

Thank you.
Comment 4 Pete Zaitcev 2006-04-13 02:12:04 EDT
I swear this was committed long time ago. I just verified -40.6.EL,
the fix is present. Stuart, could you check if U7 has the fix and
close the bug?
Comment 5 Stuart Hayes 2006-04-13 14:48:35 EDT
It doesn't appear to be in U7 (2.4.21-40.EL).  I guess it didn't bother too 
many people, because I never heard anything else about it...
Comment 6 Ernie Petrides 2006-04-13 15:38:52 EDT
Pete, the patch in comment #2 has never been committed to the RHEL3 kernel,
and there is no reference to USB_VENDOR_ID_CHICONY in any of my patch tracking
files (across all updates).
Comment 7 Pete Zaitcev 2006-04-13 17:35:35 EDT
Oh yuk, it appears that I made Stuart to work for nothing, because
I confused unpacked trees locally. I very, very sorry.
Comment 8 Stuart Hayes 2006-04-14 10:30:11 EDT
:)  It was really no problem.
Comment 9 RHEL Product and Program Management 2007-10-19 15:08:44 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.