This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1461857 - provisioning from pxe fails when using ovirt sdk v4
provisioning from pxe fails when using ovirt sdk v4
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity high
: GA
: 5.8.1
Assigned To: Boriso
Ilanit Stein
provider:rhev
: ZStream
Depends On: 1454861
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 08:57 EDT by Satoe Imaishi
Modified: 2017-08-02 13:31 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.8.1.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1454861
Environment:
Last Closed: 2017-08-02 13:31:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: RHEVM


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2017-06-15 09:06:17 EDT
New commit detected on ManageIQ/manageiq/fine:
https://github.com/ManageIQ/manageiq/commit/5aee1ef92b9e5789e40347638c462c22d0fd9b1b

commit 5aee1ef92b9e5789e40347638c462c22d0fd9b1b
Author:     Oved Ourfali <oourfali@redhat.com>
AuthorDate: Thu Jun 1 11:17:59 2017 +0300
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Thu Jun 15 09:03:33 2017 -0400

    Merge pull request #40 from borod108/bugs/pxe_prov
    
    Fix provisioning PXE for version 4
    (cherry picked from commit b030d08510eb1fd3916df0427983dcc45a3ad36d)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1461857

 .../redhat/infra_manager/ovirt_services/strategies/v3.rb     |  6 ++++++
 .../redhat/infra_manager/ovirt_services/strategies/v4.rb     | 10 ++++++++++
 .../redhat/infra_manager/provision/configuration/network.rb  | 12 +++---------
 .../infra_manager/provision/configuration/network_spec.rb    |  4 ++++
 4 files changed, 23 insertions(+), 9 deletions(-)
Comment 3 Ilanit Stein 2017-06-28 16:06:52 EDT
Verified on CFME-5.8.1.0/RHV-4.1.3
/var/www/miq/vmdb/config/settings.yml and set use_ovirt_engine_sdk to true, 
and restarted evmserverd service.
VM provision from PXE succeeded, without any errors.
(This was done without using the customized tab dialog in VM provision).
Comment 5 errata-xmlrpc 2017-08-02 13:31:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:1758

Note You need to log in before you can comment on or make changes to this bug.