Bug 146191 - Recurring kernel crashes
Recurring kernel crashes
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-01-25 16:15 EST by Göran Uddeborg
Modified: 2015-01-04 17:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-01-25 16:23:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Console log from one crash, starting with boot sequence (37.22 KB, text/plain)
2005-01-25 16:17 EST, Göran Uddeborg
no flags Details
A second example (99.47 KB, text/plain)
2005-01-25 16:18 EST, Göran Uddeborg
no flags Details

  None (edit)
Description Göran Uddeborg 2005-01-25 16:15:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; sv-SE; rv:1.7.3)

Description of problem:
After upgrading to the current kernel, the machine has become
unstable.  It was previously running a custom built 2.4 kernel.  With
that, we did not have those problems.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
I have no obvious way to trigger it.  It APPEARS to only happen when
doing things in Mozilla, but that could of course be a coincidence.  A
significant part of the time used with this machine is spent with Mozilla.

Additional info:

I've tried to disable as much as possible.  I have previously been
running with several sensors modules loaded, with acpi=force, etc, and
it has worked.  To try to isolate the cause, I've excluded many such
"extras", but I still get the crashes.

To get any information at all, I've connected a serial console, and
done a couple of SysRq commands at the crashes.  I'll attach the two
most recent of those to this bug.
Comment 1 Göran Uddeborg 2005-01-25 16:17:43 EST
Created attachment 110218 [details]
Console log from one crash, starting with boot sequence

Translatable system messages are in Swedish, but I think all part you may find
important should be easily recognised.
Comment 2 Göran Uddeborg 2005-01-25 16:18:45 EST
Created attachment 110219 [details]
A second example
Comment 3 Dave Jones 2005-01-25 16:23:58 EST
Red Hat Linux release 6.1 (Cartman)
Kernel 2.6.10-1.741_FC3 on an i686

There's little surprise things break. Your userspace is way too old.
It could be any number of things, though my bet is on a glibc->kernel
space interaction.

Your only hope is to update your userspace to Fedora.
Comment 4 Göran Uddeborg 2005-01-25 16:34:39 EST
Could you explain what you mean with "userspace"?  I do, for example,
have glibc-2.3.4-2.fc3, which I believe is the current one. 
module-init-tools is 3.1-0.pre5.3, and initscripts 7.93.5-1.

There are surely a few old programs around.  But just running an old
program should not be a way to crash the kernel, should it?

Could you be a bit more precise?
Comment 5 Dave Jones 2005-01-25 16:47:40 EST
what exactly did you do to get this state ? It appears that youve
taken an rhl6.1 box, and installed a bunch of fc3 rpms on top ?
What did you upgrade altogether ?

There's just no way we can support such configurations. Unless you
have a completely FC3 based userspace, bugs against the FC3 kernel are

I'm not aware of any backtraces similar to those you posted in
bugzilla, which leads me to believe this is an isolated incident.
Comment 6 Göran Uddeborg 2005-01-25 17:18:33 EST
Aha, you mean the /etc/issue message!  THAT isn't true.  (The
background is a bit too long for a bugzilla.)

I have upgraded individual packages, not everything at once.  But
I do believe all RELEVANT packages are from FC3.

Certainly, not EVERY package is from that release.  I still have an
old copy of bsd-games for an extreme example.  (And fedora-release is
not pure either, as you noticed.)  But is that really a reason to say
it can't be supported?  In my understanding, true userspace
programs/packages like that should not be able to crash a kernel.
Packages like initscripts and module-init-tools, sure!  But the list
should be pretty short, I would have thought.

(If it actually WAS bsd-games causing a crash, it would have been a
bit of a too trivial local DoS attack.  But I haven't been running
anything from bsd-games. :-)

It may be that you haven't seen any similar backtraces.  It may be
that it is particular for only this machine.  And you may obviously
choose not to do any further investigations on this bugzilla.  That is
certainly up to you.  But I do find the reasoning about old userspace
packages a bit strange.
Comment 7 Mike A. Harris 2005-01-25 17:39:52 EST
We support an OS release we ship as a whole unit.  People who
want to have a reasonable chance of their issue being investigated
are expected to be running the entire operating system that we
maintain, rather than mixed bits and pieces from various releases
over the years.  This is not an unreasonable thing.

That doesn't mean there is no kernel bug.  There may or may not
be one, but your system isn't a supported configuration, nor is
it one that is easy for someone to set up and try to reproduce
anything.  There isn't enough other detail to be able to hypothesize
much about the issue either.

Here are a few options for you to consider which may help find
a solution to the problem you're experiencing:

1) Track down a specific test case that is reproduceable 100% of
the time and post the details of how to reproduce it on a stock
FC3 OS install.

2) Do a fresh OS install (not an upgrade) of FC3 and try to
   reproduce the problem.  (using a different hard disk or
   partition if necessary.

If you can isolate the problem to a specific kernel issue, or if
you can provide information on how to reliably reproduce the issue
in an official Fedora Core 3 OS install, update the report with
those details.

Random Frankenstein OS installs are not maintained nor supported
however, so be wary of that.  ;o)
Comment 8 Göran Uddeborg 2005-01-26 03:18:38 EST
I see.

Note You need to log in before you can comment on or make changes to this bug.