Bug 1461949 - [DOCS] Guide fails to provide guidance on critical setup parameter
[DOCS] Guide fails to provide guidance on critical setup parameter
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-RHEL-Atomic (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Negus
Vikram Goyal
Vikram Goyal
: Documentation, Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 13:13 EDT by Simo Sorce
Modified: 2017-11-13 15:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-13 15:23:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simo Sorce 2017-06-15 13:13:17 EDT
This guide:
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux_atomic_host/7/html-single/getting_started_with_kubernetes/

Assumes a network configuration for the kubernetes cluster w/o giving any guidance or even pointing out that parameters may be different in the user's setup.

Specifically the guide instructs the user to create an apiserver-pod.json file to configure the api server to serve applications via the cluster-ip-range 10.254.0.0/16 without giving information about how to set up such network or what other options should be used.

After the guide is run through the user is stuck not being able to test if the containers are working because no such network has been created/is routed to the client.
Comment 2 Chris Negus 2017-10-12 09:17:30 EDT
The IP address range identified with service-cluster-ip-range is used internally by Kubernetes to assign addresses to services used on each Kubernetes node. I added a description of that option to the guide. It is scheduled to be published with RHEL/Atomic 7.4.2 on 10/17/2017.

Note You need to log in before you can comment on or make changes to this bug.