Bug 1461973 - [RFE] Auto-generate PostgreSQL password for cfme-openshift pods
[RFE] Auto-generate PostgreSQL password for cfme-openshift pods
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: cfme-openshift-app-docker (Show other bugs)
5.8.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.8.1
Assigned To: Satoe Imaishi
Einat Pacifici
Red Hat CloudForms Documentation
: FutureFeature, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 15:12 EDT by Satoe Imaishi
Modified: 2017-08-02 13:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.8.1.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 13:11:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Container Management


Attachments (Terms of Use)

  None (edit)
Description Satoe Imaishi 2017-06-15 15:12:10 EDT
From: https://github.com/ManageIQ/manageiq-pods/issues/105

Current ability of configuring a password for PostgreSQL (DATABASE_PASSWORD) is handy but in case it's not defined it shouldn't be a known default password "smartvm" but rather a random generated one (and stored as a secret).
Comment 2 Satoe Imaishi 2017-06-15 15:14:37 EDT
Upstream fixed by Franco: https://github.com/ManageIQ/manageiq-pods/pull/118
Comment 4 Einat Pacifici 2017-08-01 03:50:43 EDT
Verified. 
Followed: 
https://github.com/ManageIQ/manageiq-pods/pull/118

After complete install of podified CFME on OCP3.5
Ran the command: 
[root@cmqe-podified-master ~]# oc describe pods cloudforms-0 | grep PASSW
Response: 
      POSTGRESQL_PASSWORD:		<set to the key 'pg-password' in secret 'cloudforms-secrets'>
Comment 6 errata-xmlrpc 2017-08-02 13:11:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1757

Note You need to log in before you can comment on or make changes to this bug.