Bug 1461982 - validation check for "Verify existence of deployment images." reports missing images but images are present
Summary: validation check for "Verify existence of deployment images." reports missing...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 11.0 (Ocata)
Hardware: All
OS: Linux
high
high
Target Milestone: beta
: 12.0 (Pike)
Assignee: RHOS Maint
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks: 1463718
TreeView+ depends on / blocked
 
Reported: 2017-06-15 19:41 UTC by jgershat
Modified: 2018-02-05 19:07 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-validations-7.4.2-0.20171016115241.c2c9bf2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1463718 (view as bug list)
Environment:
Last Closed: 2017-12-13 21:32:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
error showing images missing (69.58 KB, image/png)
2017-06-15 19:41 UTC, jgershat
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 482979 0 None None None 2017-09-25 13:08:15 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description jgershat 2017-06-15 19:41:56 UTC
Created attachment 1288166 [details]
error showing images missing

Description of problem:
I click the validation check for "Verify existence of deployment images." and it reports missing images but images are present

Version-Release number of selected component (if applicable):
RHOSP11

How reproducible:
click the validation check


Steps to Reproduce:
1. login as admin
2. click validation for deployment images
3.

Actual results:
missing

Expected results:
present

Additional info:
I run the command at the command line and it shows images present

[stack@jonathan9 images]$ openstack image list
Missing value auth-url required for auth plugin password
[stack@jonathan9 images]$ source ~/stackrc
[stack@jonathan9 images]$ openstack image list
+--------------------------------------+------------------------+--------+
| ID                                   | Name                   | Status |
+--------------------------------------+------------------------+--------+
| af1ae324-3f85-4e34-99be-b53f919f498f | bm-deploy-kernel       | active |
| 6b974e3a-d204-47be-bbf1-2cff809eddbc | bm-deploy-ramdisk      | active |
| c9836587-523e-4140-b51f-c643db8eaa5b | overcloud-full         | active |
| 8afdaf56-ec93-4d6c-95de-4da90ae97954 | overcloud-full-initrd  | active |
| a04119d3-9c75-47ae-885c-e1c78a5f1cd0 | overcloud-full-vmlinuz | active |
+--------------------------------------+------------------------+--------+
[stack@jonathan9 images]$ ls -l /httpboot
total 363644
-rwxr-xr-x. 1 root             root               5394272 Jun 12 12:57 agent.kernel
-rw-r--r--. 1 root             root             366972367 Jun 12 12:57 agent.ramdisk
-rw-r--r--. 1 ironic-inspector ironic-inspector       456 Jun 12 12:10 inspector.ipxe

See attachment for error I receive in the UI

Comment 7 errata-xmlrpc 2017-12-13 21:32:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.