Bug 1462071 - blivet.errors.LUKSError: luks device not configured
blivet.errors.LUKSError: luks device not configured
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blivet-gui (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vojtech Trefny
Fedora Extras Quality Assurance
abrt_hash:e8a04c5324522e879e5e1528a3a...
:
: 1466946 1488154 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-16 02:00 EDT by Steve
Modified: 2017-09-05 01:34 EDT (History)
9 users (show)

See Also:
Fixed In Version: blivet-gui-2.1.5-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-23 10:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (379.28 KB, text/plain)
2017-06-16 02:01 EDT, Steve
no flags Details
File: environ (529 bytes, text/plain)
2017-06-16 02:01 EDT, Steve
no flags Details
File: lsblk_output (2.88 KB, text/plain)
2017-06-16 02:01 EDT, Steve
no flags Details
File: nmcli_dev_list (1.88 KB, text/plain)
2017-06-16 02:01 EDT, Steve
no flags Details
File: os_info (447 bytes, text/plain)
2017-06-16 02:01 EDT, Steve
no flags Details

  None (edit)
Description Steve 2017-06-16 02:00:53 EDT
Description of problem:
Intaller, formatting using new tool, Reformat /boot & / keep exising /home. root and home on luks

Version-Release number of selected component:
anaconda-26.21.7-1

The following was filed automatically by anaconda:
anaconda 26.21.7-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.6/site-packages/blivet/formats/luks.py", line 209, in _pre_setup
    raise LUKSError("luks device not configured")
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/formats/__init__.py", line 599, in setup
    if not self._pre_setup(**kwargs):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 506, in setup_parents
    _format.setup()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 363, in _pre_setup
    self.setup_parents(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 374, in setup
    if not self._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 498, in setup_parents
    parent.setup(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 363, in _pre_setup
    self.setup_parents(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 225, in _pre_setup
    return StorageDevice._pre_setup(self, orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 374, in setup
    if not self._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/device.py", line 209, in setup_parents
    parent.setup(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1894, in setup_parents
    Device.setup_parents(self, orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 363, in _pre_setup
    self.setup_parents(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 868, in _pre_setup
    if not super(LVMLogicalVolumeBase, self)._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 374, in setup
    if not self._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1898, in setup
    return DMDevice.setup(self, orig)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1801, in decorated
    return meth(self, *args, **kwargs)  # pylint: disable=not-callable
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/deviceaction.py", line 695, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 325, in process
    action.execute(callbacks)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 48, in wrapped_func
    return func(obj, *args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 163, in do_it
    self.devicetree.actions.process(callbacks=callbacks, devices=self.devices)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/osinstall.py", line 1112, in turn_on_filesystems
    storage.do_it(callbacks)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 437, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 471, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 303, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 303, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install.py", line 356, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threads.py", line 251, in run
    threading.Thread.run(self, *args, **kwargs)
blivet.errors.LUKSError: luks device not configured

Additional info:
addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-2.fc26.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        26
Comment 1 Steve 2017-06-16 02:01:01 EDT
Created attachment 1288257 [details]
File: anaconda-tb
Comment 2 Steve 2017-06-16 02:01:03 EDT
Created attachment 1288258 [details]
File: environ
Comment 3 Steve 2017-06-16 02:01:05 EDT
Created attachment 1288259 [details]
File: lsblk_output
Comment 4 Steve 2017-06-16 02:01:07 EDT
Created attachment 1288260 [details]
File: nmcli_dev_list
Comment 5 Steve 2017-06-16 02:01:09 EDT
Created attachment 1288261 [details]
File: os_info
Comment 6 Fedora Update System 2017-06-20 02:48:42 EDT
blivet-gui-2.1.5-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4fa8dcbca7
Comment 7 Fedora Update System 2017-06-21 02:23:09 EDT
blivet-gui-2.1.5-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4fa8dcbca7
Comment 8 Fedora Update System 2017-06-23 10:19:37 EDT
blivet-gui-2.1.5-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Vojtech Trefny 2017-07-03 03:10:50 EDT
*** Bug 1466946 has been marked as a duplicate of this bug. ***
Comment 10 Vojtech Trefny 2017-09-05 01:34:44 EDT
*** Bug 1488154 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.