Bug 1462079 - [gfapi statedump] : client parameter accepts garbage inputs and shows success on stdout..
Summary: [gfapi statedump] : client parameter accepts garbage inputs and shows succes...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.3
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
: ---
Assignee: Atin Mukherjee
QA Contact: Bala Konda Reddy M
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-16 06:51 UTC by Ambarish
Modified: 2019-10-16 02:55 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Statedump reports success even when it fails because of incorrect client host value, for example: # gluster volume statedump <replaceable>volume</replaceable> client <not-a-host>:<port> To work around this issue, ensure the value of <host> is correct.
Clone Of:
Environment:
Last Closed: 2018-10-31 11:19:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ambarish 2017-06-16 06:51:31 UTC
Description of problem:
-----------------------

Client parameter is accepting garbage values as inputs :

[root@gqas007 gluster]# gluster v statedump testvol  client garbage:3343
volume statedump: success

[root@gqas007 gluster]# gluster v statedump testvol  client cljfeuoregfourehfreouvfohre:3343
volume statedump: success
[root@gqas007 gluster]#


Version-Release number of selected component (if applicable):
--------------------------------------------------------------

glusterfs-3.8.4-25.el7rhgs.x86_64

How reproducible:
-----------------

Every which way I try.


Note You need to log in before you can comment on or make changes to this bug.