Bug 1462084 - environment-rhel-registration.yaml doesn't allow multiple rhel_reg_pool_id's
environment-rhel-registration.yaml doesn't allow multiple rhel_reg_pool_id's
Status: CLOSED DUPLICATE of bug 1430545
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
11.0 (Ocata)
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Emilien Macchi
Gurenko Alex
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-16 03:07 EDT by August Simonelli
Modified: 2017-06-18 20:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 08:31:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description August Simonelli 2017-06-16 03:07:33 EDT
Description of problem:

OSP director RHEL registration templates (tripleo-heat-templates/extraconfig/pre_deploy/rhel-registration/environment-rhel-registration.yaml) don't allow you to specify more than one value for rhel_reg_pool_id. 

The rhel-registration logic also can't be applied on a pre-role basis and needs to be.

To account for the different SKU's required by different nodes in the overcloud there are multiple pool ids required in a deployment. Those id's need to be applied per role so that controller sku's can be matched to a controller, ceph skus to storage and compute sku's to computes.

Without this, all nodes get the ONE pool id, which means they are getting the wrong SKU.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-12.el7ost

How reproducible:


Steps to Reproduce:
1. Deploy OSP with director 
2. Put a rhel_reg_pool_id into environment-rhel-registration.yaml


Actual results:
rhel_reg_pool_id is assigned to all nodes.

Expected results:
There should be a way to put multiple pools in and assign them per role (or node)

Additional info:
Comment 2 Emilien Macchi 2017-06-16 08:31:57 EDT
Please confirm but I think it's duplicated of https://bugzilla.redhat.com/show_bug.cgi?id=1430545  (Re-open if I was wrong).

*** This bug has been marked as a duplicate of bug 1430545 ***
Comment 3 August Simonelli 2017-06-18 20:02:14 EDT
Thanks Emilien! Yes that's perfect.

Note You need to log in before you can comment on or make changes to this bug.