Bug 146209 - sendmail auth wont work with yp(nis) by defualt
sendmail auth wont work with yp(nis) by defualt
Status: CLOSED DUPLICATE of bug 159194
Product: Fedora
Classification: Fedora
Component: cyrus-sasl (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 18:45 EST by Chris Jones
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 06:55:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Jones 2005-01-25 18:45:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050110 Firefox/1.0 (Debian package 1.0+dfsg.1-2)

Description of problem:
/etc/sysconfig/saslauthd sets the defualt authentication mechinism to shaddow, rather than pam, this breaks auth for anyone not useing shadow

MECH=shadow


Version-Release number of selected component (if applicable):
sendmail-8.13.1-2

How reproducible:
Always

Steps to Reproduce:
1. Install sendmail
2. Install yp (nis)
3. Setup sendmail to use auth on sending
4. Try to send mail, useing auth from a valid yp user

Actual Results:  Failed to send mail, with user/password unknown type error

Expected Results:  Mail should have been accepted, as the user is a valid user

Additional info:
Comment 1 Sitsofe Wheeler 2005-01-26 02:46:17 EST
I think you got the component wrong. /etc/sysconfig/saslauthd is owned by
cyrus-sasl-2.1.19-3 ...
Comment 2 Walter Justen 2005-08-26 06:55:21 EDT
Thanks for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 159194 ***

Note You need to log in before you can comment on or make changes to this bug.