Bug 1462184 - curl broken with openssl-libs < 1.1.0f-1
curl broken with openssl-libs < 1.1.0f-1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-16 07:52 EDT by Nikola Forró
Modified: 2017-06-19 08:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: curl-7.54.1-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-19 08:31:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikola Forró 2017-06-16 07:52:58 EDT
Description of problem:
Updating curl to 7.54.1-1 while having openssl-libs < 1.1.0f-1 installed breaks everything using (lib)curl, including dnf.

Version-Release number of selected component (if applicable):
curl-7.54.1-1.fc27.x86_64
libcurl-7.54.1-1.fc27.x86_64

How reproducible:
always

Steps to Reproduce:
1. # rpm -q openssl-libs
openssl-libs-1.1.0e-1.fc27.x86_64
2. # rpm -q {,lib}curl
curl-7.53.1-3.fc27.x86_64
libcurl-7.53.1-3.fc27.x86_64
3. # dnf upgrade libcurl
4. # curl --help

Actual results:
curl: relocation error: /lib64/libcurl.so.4: symbol SSL_CTX_set_srp_username, version OPENSSL_1_1_0 not defined in file libssl.so.1.1 with link time reference

Expected results:
no error
Comment 1 Kamil Dudka 2017-06-16 12:54:30 EDT
Thank you for reporting the bug!  I will have a look on Monday when I am back from my vacation.  CC'ing the maintainer of openssl as it looks like the cause.  Its library/symbol versioning seems to be either insufficient, or not taken into account by the dependency scanner of rpmbuild.

Note You need to log in before you can comment on or make changes to this bug.