Bug 146222 - Fritz!Card does not work under kernel 2.6
Fritz!Card does not work under kernel 2.6
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 21:12 EST by Enrico Scholz
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-04 04:20:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2005-01-25 21:12:09 EST
Description of problem:

[ This is a CC of the upstream report available at
  http://listserv.isdn4linux.de/pipermail/isdn4linux/2005-January/001162.html

  perhaps it is caused by some RHizms which can be solved here...

  Alternatively, the ISDN infrastructure should be updated to mISDN ]

=========================

Hi,

I try to use my Fritz PCI ISDN card with Linux 2.6 but had not very much
success with this :(

The driver will be loaded without problems but when I try to dial a number,
a hangup happens immediately afte 2-3 seconds. Some observations:

* /proc/interrupts does not show any activity for the used IRQ when the
  driver is loaded; under linux 2.4 I see periodic interrupts (the IRQ
  is not shared). During the initialization phase of the driver I see 3
  IRQs under 2.6 and 5 under 2.4

* /dev/isdnctl does not show any entry; under 2.4 I see periodic status
  reports there. 'isdnlog' is stopped and 'hisaxctl 11 -1' was executed.

* on the first incoming call I see a 'hdlc spurious channel 0 IRQ'
  message which will not be shown on subsequent calls.

* outgoing calls to a mobile phone or another telephone do not seem to
  have an effect (no ringing)

* I use the same userspace configuration under kernel 2.4 and 2.6 but
  only the 2.4 one works. The ISDN specific kernelconfiguration matches
  for both kernels


Some information about the system:

* vanilla 2.6.10 kernel or Fedora Core 2.6.10-1.741_FC3 kernel
  ==>  no success

* vanilla 2.4.27 kernel  ==>  success

* AMD K6-2 500 CPU, Asus P5A board

* 'acpi=off' and 'acpi=on' and enabling/disabling of 'PNP OS' in the
  BIOS settings have been tried without any success

* CONFIG_PNP kernel-setting is enabled and turning it off does not
  change anything

* the ISDN has been tried in another PCI slot (with IRQ sharing) but it
  gives the same results as above

* the module parameters are 'type=27 protocol=2'



Yet more information, logmessages and more can be found at

             http://www-user.tu-chemnitz.de/~ensc/hw/londo



Version-Release number of selected component (if applicable):

isdn4k-utils-3.2-21
kernel-2.6.10-1.741_FC3
Comment 1 Ngo Than 2005-09-01 11:03:07 EDT
it looks like a bug in kernel (hisax isdn driver). Could you please
update to new version of kernel from FC3 and try again? thanks
Comment 2 Dave Jones 2005-10-04 04:20:25 EDT
you're actually much more likely to get this fixed by reporting the bug to the
upstream maintainers, as they likely have the hardware to debug this.

Their mailing list is listed as isdn4linux@listserv.isdn4linux.de

But as was requested in the previous comment, try a newer kernel first.
(Though I'm not optimistic, as I don't recall many isdn changes recently)

Note You need to log in before you can comment on or make changes to this bug.