Description of problem:
gsview-4.6-8.x86_64.rpm fails to find /usr/lib64/libgs.so
Needs a change to "Requires: libgs.so.7" in the gsview.spec
Version-Release number of selected component (if applicable):
Steps to Reproduce:
Created attachment 110236 [details]
patch to gsview.spec
The patch doesn't look correct.
The x86_64 ghostscript packages provides libgs.so.7, but x86_64 RPM
knowledge is needed here:
$ rpm -qp ghostscript-7.07-33.x86_64.rpm --provides | grep libgs
$ rpm -qlp ghostscript-7.07-33.x86_64.rpm | grep libgs
I accept that it may not be the *right* patch, but it works for me
on x86_64 with only the x86_64 version of ghostscript-7.07-37
installed (no i386).
Apparently "Requires: libgs.so.7" doesn't find the version in
/usr/lib64/, but "Requires: ghostscript >= 7.07-15.3" does.
Sure, "Requires: ghostscript >= 7.07-15.3" _assumes_ that package
ghostscript >= 7.07-15.3 provides the needed libgs.so.7. We can safely
assume that, as long as we know the library soname is included in the
right place. It's still only a workaround for what the original
dependency tried to achieve.
I have no problem changing the dependancy.
* Wed Jan 26 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0:4.6-9
- back to Req: ghostscript >= 7.07-15.3 for x86_64 (#146223)
Just noticed; this seems to be fixed in cvs. Can anybody close?
I was waiting for updated/fixed binaries before closing the bug. (And
I believe that part is my fault for not actually requesting a new