Bug 146223 - gsview-4.6-8.x86_64.rpm fails to find /usr/lib64/libgs.so
gsview-4.6-8.x86_64.rpm fails to find /usr/lib64/libgs.so
Product: Fedora
Classification: Fedora
Component: gsview (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Depends On:
  Show dependency treegraph
Reported: 2005-01-25 21:21 EST by John Ellson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-06-22 12:40:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch to gsview.spec (539 bytes, patch)
2005-01-25 21:23 EST, John Ellson
no flags Details | Diff

  None (edit)
Description John Ellson 2005-01-25 21:21:58 EST
Description of problem:
gsview-4.6-8.x86_64.rpm  fails to find /usr/lib64/libgs.so

Needs a change to "Requires: libgs.so.7" in the gsview.spec

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Patch follows
Comment 1 John Ellson 2005-01-25 21:23:07 EST
Created attachment 110236 [details]
patch to gsview.spec
Comment 2 Michael Schwendt 2005-01-25 21:56:19 EST
The patch doesn't look correct.

The x86_64 ghostscript packages provides libgs.so.7, but x86_64 RPM
knowledge is needed here:

$ rpm -qp ghostscript-7.07-33.x86_64.rpm --provides | grep libgs

$ rpm -qlp ghostscript-7.07-33.x86_64.rpm | grep libgs
Comment 3 John Ellson 2005-01-25 22:37:58 EST
I accept that it may not be the *right* patch, but it works for me
on x86_64 with only the x86_64 version of ghostscript-7.07-37
installed (no i386).

Apparently "Requires: libgs.so.7" doesn't find the version in
/usr/lib64/, but "Requires: ghostscript >= 7.07-15.3" does.
Comment 4 Michael Schwendt 2005-01-26 04:58:40 EST
Sure, "Requires: ghostscript >= 7.07-15.3" _assumes_ that package
ghostscript >= 7.07-15.3 provides the needed libgs.so.7. We can safely
assume that, as long as we know the library soname is included in the
right place. It's still only a workaround for what the original
dependency tried to achieve.
Comment 5 Rex Dieter 2005-01-26 08:20:08 EST
OK, goofy.  

I have no problem changing the dependancy.
Comment 6 Rex Dieter 2005-01-26 10:31:10 EST
* Wed Jan 26 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0:4.6-9
- back to Req: ghostscript >= 7.07-15.3 for x86_64 (#146223)
Comment 8 Thorsten Leemhuis 2005-03-06 09:37:34 EST
Just noticed; this seems to be fixed in cvs. Can anybody close?
Comment 9 Rex Dieter 2005-03-06 15:22:32 EST
I was waiting for updated/fixed binaries before closing the bug.  (And
I believe that part is my fault for not actually requesting a new
build yet)

Note You need to log in before you can comment on or make changes to this bug.