Bug 146226 - FHS violation: Libraries, etc should be in /usr, not /usr/X11R6
FHS violation: Libraries, etc should be in /usr, not /usr/X11R6
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xbae (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 23:14 EST by Mike A. Harris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 04:44:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2005-01-25 23:14:47 EST
Description of problem:

Xbae installs itself into /usr/X11R6, which is explicitly reserved
by the FHS 2.3 for the X Window System Release 6.  There are a
few things that violate this, however they all need to be
repaired to install themselves into the /usr hierarchy as soon
as possible, because /usr/X11R6 will no longer be used when
X11R7 is released within the next year.  Having said that,
there may be an X.Org migratory period, where /usr/X11R6 and
it's various subdirectories remain for backward compatibility
for a few releases, but the hierarchy is considered obsolete
by many, and will be removed.

Please reconfigure this package to install everything into
/usr, and confirm it doesn't put anything into /usr/X11R6.

Also, if you're aware of any other packages that install things
into /usr/X11R6, please report bugs against them as well, and
cut and paste this comment into the bug report, changing the
package name as appropriate.

By making these changes now, anything that breaks will have
more time to be fixed cleanly over time, than a massive breakage
all at once when the change is forced in a year or whenever it
occurs.

Thanks in advance.
Comment 1 Ngo Than 2005-01-26 04:44:09 EST
Xbae is not included since FC2. I close it as wontfix

Note You need to log in before you can comment on or make changes to this bug.