Bug 1462290 - [Docs][Ceph] Fix RHOSP 11 guide for backwards_compatibility_with_older_versions_of_red_hat_ceph_storage
[Docs][Ceph] Fix RHOSP 11 guide for backwards_compatibility_with_older_versio...
Status: CLOSED DUPLICATE of bug 1422742
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
high Severity unspecified
: async
: 11.0 (Ocata)
Assigned To: RHOS Documentation Team
RHOS Documentation Team
: Documentation
Depends On:
  Show dependency treegraph
Reported: 2017-06-16 11:38 EDT by Andreas Karis
Modified: 2017-08-31 21:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-08-31 21:53:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andreas Karis 2017-06-16 11:38:13 EDT
Description of problem:

This is only a copy of the OSP 10 approach.

**Note:** The approach for OSP 10 does **not** work for OSP 11. At the time of this writing, [https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/html-single/red_hat_ceph_storage_for_the_overcloud/#backwards_compatibility_with_older_versions_of_red_hat_ceph_storage](https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/html-single/red_hat_ceph_storage_for_the_overcloud/#backwards_compatibility_with_older_versions_of_red_hat_ceph_storage) contains the wrong instructions which are only valid for OSP 10.

Additional info:

In Red Hat OpenStack Platform 11, one can enable backwards compatibility by adding the following to one of the environment files, e.g. `storage-environment.yaml`:
  RbdDefaultFeatures: 1
> If one is using a local copy of `/usr/share/openstack-tripleo-heat-templates/environments/puppet-ceph-external.yaml`, e.g. `cp /usr/share/openstack-tripleo-heat-templates/environments/puppet-ceph-external.yaml /home/stack/templates/`, then one can remove the comment in front of `# RbdDefaultFeatures: 1`
Comment 1 Lucy Bopf 2017-08-31 21:53:35 EDT
Looks like this has now been fixed as part of bug 1422742.

Closing. Please reopen if the issues persists.

*** This bug has been marked as a duplicate of bug 1422742 ***

Note You need to log in before you can comment on or make changes to this bug.