Bug 1462310 - missing default cfg on rawhide
missing default cfg on rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
: 1461839 1469699 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-16 13:15 EDT by Lukas Slebodnik
Modified: 2017-08-23 06:29 EDT (History)
9 users (show)

See Also:
Fixed In Version: mock-1.4.3-1.fc26 mock-1.4.3-1.fc25 mock-1.4.3-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 12:54:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Slebodnik 2017-06-16 13:15:28 EDT
Description of problem:
There is a missing default.cfg after installing on rawhide

Version-Release number of selected component (if applicable):
sh$ rpm -q mock
mock-1.4.2-1.fc27.noarch

How reproducible:
Deterministic

Steps to Reproduce:
1. //install mock on minimal rawhide
   docker run --rm -ti fedora:rawhide bash
2. dnf install -y mock
3. ls -l /etc/mock/default.cfg

Actual results:
sh$ ls -l /etc/mock/default.cfg
ls: cannot access '/etc/mock/default.cfg': No such file or directory

Expected results:
sh$ ls -l /etc/mock/default.cfg
lrwxrwxrwx. 1 root root 20 Apr 29 09:57 /etc/mock/default.cfg -> fedora-rawhide-x86_64.cfg

Additional info:
There is an error in rpm scriptlet

  Installing  : mock-1.4.2-1.fc27.noarch                                  40/50 
/var/tmp/rpm-tmp.wLYr98: line 15: python: command not found
Warning: file /etc/mock/fedora-rawhide-.cfg does not exists.
         unable to update /etc/mock/default.cfg
Comment 1 Lukas Slebodnik 2017-06-28 15:49:11 EDT
Moving to f26 because I can easily reproduce with f26 docker image
registry.fedoraproject.org/fedora:26
Comment 2 Miroslav Suchý 2017-07-03 10:50:05 EDT
Fixed in commit 8cacc2355cbf3dc36a72d48f8f0c9f7d6936bd37

Previously we called python in %post and this is no longer true. So for Fedoras we now call python3 script.
Comment 3 Lukas Slebodnik 2017-07-06 16:09:39 EDT
mock-1.4.2-1.fc25 does not depend on yum or any other python2 package.
But it still use python(python2) in scriptlet.

BTW mock in f24 still depends on yum and therefore there is not such problem.
Comment 4 Miroslav Suchý 2017-07-11 04:45:21 EDT
Ops, I forgot to 'git push' it. Correct commit is 1874608
Comment 5 Miroslav Suchý 2017-07-11 04:46:32 EDT
> BTW mock in f24 still depends on yum and therefore there is not such problem.

In upstream it is: 
  Suggests: yum
So you can have mock without yum.
Comment 6 Lukas Slebodnik 2017-07-11 17:07:41 EDT
(In reply to Miroslav Suchý from comment #5)
> > BTW mock in f24 still depends on yum and therefore there is not such problem.
> 
> In upstream it is: 
>   Suggests: yum
> So you can have mock without yum.

"Suggests: yum" is not proper solution in rawhide
Because there will be still missing default cfg in case of
  "dnf --setopt=install_weak_deps=false install mock"
And IIRC microdnf should have disabled weak deps by default.

mock depends on python3 and therefore shoudl use python3 in scriptlets

sh$ rpm -q --requires mock | grep python3
/usr/bin/python3
python3
python3-distro
python3-requests
python3-six >= 1.4.0
rpm-python3

sh$ rpm -q --scripts mock | grep python
mock_arch=$(python -c "import rpmUtils.arch; baseArch = rpmUtils.arch.getBaseArch(); print baseArch")
Comment 7 Branko Grubić 2017-07-12 13:25:55 EDT
This is the same issue as bug #1461839 it's against different releases, since I'm not sure I won't close it as duplicate.
Comment 8 Miroslav Suchý 2017-07-13 10:11:10 EDT
> "Suggests: yum" is not proper solution in rawhide
That was just my reply that mock still depend on yum. It does not depend anymore.

See the commit that fixes this BZ https://github.com/rpm-software-management/mock/commit/1874608000f1f3f695e651b9447e450cf8c81e75 
Mock is now using python3 and hawkey module to detect arch.
Comment 9 Lukas Slebodnik 2017-07-17 05:45:40 EDT
(In reply to Miroslav Suchý from comment #8)
> > "Suggests: yum" is not proper solution in rawhide
> That was just my reply that mock still depend on yum. It does not depend
> anymore.
>

I see
 
> See the commit that fixes this BZ
> https://github.com/rpm-software-management/mock/commit/
> 1874608000f1f3f695e651b9447e450cf8c81e75 
> Mock is now using python3 and hawkey module to detect arch.

OK, then please change state of BZ so you won't forget to close BZ with update in koji. I am use POST for fixed issues in upstream but missing fix in downstream.
But you might have different workflow.
Comment 10 Miroslav Suchý 2017-07-31 05:58:18 EDT
*** Bug 1461839 has been marked as a duplicate of this bug. ***
Comment 11 Miroslav Suchý 2017-08-06 18:02:31 EDT
*** Bug 1469699 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2017-08-06 19:46:19 EDT
mock-1.4.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-53f9c9cb51
Comment 13 Fedora Update System 2017-08-06 19:46:49 EDT
mock-1.4.3-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-204acb9aa4
Comment 14 Fedora Update System 2017-08-06 19:47:21 EDT
mock-1.4.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4ee5b66a4c
Comment 15 Fedora Update System 2017-08-07 17:48:59 EDT
mock-1.4.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-53f9c9cb51
Comment 16 Fedora Update System 2017-08-07 18:25:30 EDT
mock-1.4.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4ee5b66a4c
Comment 17 Fedora Update System 2017-08-07 21:23:25 EDT
mock-1.4.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-204acb9aa4
Comment 18 Fedora Update System 2017-08-10 12:54:58 EDT
mock-1.4.3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2017-08-22 08:48:28 EDT
mock-1.4.3-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2017-08-23 06:29:04 EDT
mock-1.4.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.