Bug 1462328 - Move Contrail role communication towards OpenStack APIs from public to internal_api network
Move Contrail role communication towards OpenStack APIs from public to intern...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
low Severity medium
: ga
: 12.0 (Pike)
Assigned To: Emilien Macchi
Ofer Blaut
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-16 14:05 EDT by Michael Henkel
Modified: 2018-02-05 14:07 EST (History)
12 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-7.0.3-0.20171023134947.8da5e1f.el7ost puppet-tripleo-7.4.3-0.20171019174214.1e9000a.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:32:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 475045 None None None 2017-06-16 14:27 EDT
OpenStack gerrit 475048 None None None 2017-06-16 14:27 EDT

  None (edit)
Description Michael Henkel 2017-06-16 14:05:54 EDT
Description of problem:
Currently Contrail roles use the public/external network for communicating with the 
OpenStack APIs. It must use internal_api

Version-Release number of selected component (if applicable):
NA

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP with Contrail
2.
3.

Actual results:
Contrail uses public/external nw

Expected results:
Contrail uses internal/api network

Additional info:
https://review.openstack.org/475045
https://review.openstack.org/475048
Comment 1 Brent Eagles 2017-09-11 09:51:18 EDT
These patches were merged awhile ago and appear in stable/pike, setting to post.
Comment 10 errata-xmlrpc 2017-12-13 16:32:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.