Bug 1462337 - cmdtest requires python-markdown
cmdtest requires python-markdown
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cmdtest (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1424561
  Show dependency treegraph
 
Reported: 2017-06-16 15:03 EDT by Troy Dawson
Modified: 2017-07-27 17:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 17:19:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add Requires: python-markdown (1.17 KB, patch)
2017-06-16 15:10 EDT, Troy Dawson
no flags Details | Diff

  None (edit)
Description Troy Dawson 2017-06-16 15:03:54 EDT
Description of problem:
cmdtest will not run.  It fails with a traceback.

Version-Release number of selected component (if applicable):
cmdtest-0.27-2.fc26

How reproducible:
100%

Steps to Reproduce:
1. Install cmdtest-0.27-2.fc26
2. cmdtest
3.

Actual results:
$ cmdtest
Traceback (most recent call last):
  File "/usr/bin/cmdtest", line 30, in <module>
    import yarnlib
  File "/usr/lib/python2.7/site-packages/yarnlib/__init__.py", line 20, in <module>
    from .mdparser import MarkdownParser
  File "/usr/lib/python2.7/site-packages/yarnlib/mdparser.py", line 20, in <module>
    import markdown
ImportError: No module named markdown


Expected results:
$ cmdtest
test 0/0: 
0/0 tests OK, 0 failures

Additional info:
"dnf install python-markdown" fixes the problem.
Comment 1 Troy Dawson 2017-06-16 15:10 EDT
Created attachment 1288453 [details]
Add Requires: python-markdown

Patch for spec file added.

This is a blocker for some projects.  We understand some people have limited time to fix packages.  If you do not have the time to fix this, or merge the patch, within two weeks, we will have a proven packager merge the suggested patch in and build it.
Comment 2 Troy Dawson 2017-07-27 17:19:30 EDT
Must have been a temporary dependency issue.  This is working in rawhide.  Closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.