Bug 1462373 - module load fails with "module unknown" error when running under mock --new-chroot
Summary: module load fails with "module unknown" error when running under mock --new-c...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Clark Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-16 22:15 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2017-07-06 05:19 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-25 16:19:46 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1450516 None None None Never

Internal Trackers: 1450516

Description Dominik 'Rathann' Mierzejewski 2017-06-16 22:15:38 UTC
Description of problem:
module load fails with an error when run inside mock --new-chroot.

Version-Release number of selected component (if applicable):
Lmod-7.4.20-1.fc27
Lmod-7.0-1.fc25

How reproducible:
Always.

Steps to Reproduce:
1. On Fedora 25, run: mock -r fedora-rawhide-x86_64 cp2k-4.1-1.src.rpm
   (or any other package that uses either %{_openmpi_load} macro
   or calls module load mpi/openmpi-x86_64 directly)

Actual results:
+ module load mpi/openmpi-x86_64
++ /usr/share/lmod/lmod/libexec/lmod bash load mpi/openmpi-x86_64
Lmod has detected the following error: The following module(s) are unknown:
"mpi/openmpi-x86_64"

Please check the spelling or version number. Also try "module spider ..."
It is also possible your cache file is out-of-date try:
   module --ignore-cache load "mpi/openmpi-x86_64"

Expected results:
Successful execution.

Additional info:
Running under mock --old-chroot works. Same error and workaround occurs with other buildroots, e.g. fedora-25-x86_64, too.

Comment 1 Orion Poplawski 2017-06-16 22:19:35 UTC
This is due to mock no longer starting a login shell.  Apparently fixed in upstream mock git.

Comment 2 Fedora Update System 2017-06-19 07:12:44 UTC
mock-1.4.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-21b345dd60

Comment 3 Fedora Update System 2017-06-19 07:13:45 UTC
mock-1.4.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3d88d9f8b5

Comment 4 Fedora Update System 2017-06-19 07:14:39 UTC
mock-1.4.2-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-65be829503

Comment 5 Fedora Update System 2017-06-19 14:52:52 UTC
mock-1.4.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-65be829503

Comment 6 Fedora Update System 2017-06-19 15:52:24 UTC
mock-1.4.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-21b345dd60

Comment 7 Fedora Update System 2017-06-19 19:24:36 UTC
mock-1.4.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3d88d9f8b5

Comment 8 Fedora Update System 2017-06-25 16:19:46 UTC
mock-1.4.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-07-04 01:51:44 UTC
mock-1.4.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-07-06 05:19:19 UTC
mock-1.4.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.