Bug 1462379 - Incorrect bash prompt for root after install from Workstation ostree installer image
Incorrect bash prompt for root after install from Workstation ostree installe...
Status: CLOSED DUPLICATE of bug 1193590
Product: Fedora
Classification: Fedora
Component: ostree (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-16 19:25 EDT by Adam Williamson
Modified: 2017-06-19 09:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-19 09:21:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2017-06-16 19:25:23 EDT
After installing from the Workstation ostree installer image, if you log in to a console as root (or do 'su' from a GNOME Terminal), the bash prompt looks like this:

-bash-4.4#

and not the more usual Fedora prompt:

[root@localhost root]#

Not sure why, yet, just know that it happens. (I know because this made openQA tests fail, as they expect a prompt which looks something like the latter).

Note that the prompt for a *regular user* is fine (again, both on a TTY and a GNOME terminal window):

[test@localhost test]$

It is only root's prompt that is wrong.
Comment 1 Colin Walters 2017-06-19 09:21:17 EDT

*** This bug has been marked as a duplicate of bug 1193590 ***
Comment 2 Colin Walters 2017-06-19 09:22:24 EDT
Thanks for the report.

Technically I guess we do need a separate bug for each workaround instance of this, but I'd rather we track that centrally in one BZ at the moment if you don't mind.

Note You need to log in before you can comment on or make changes to this bug.