Bug 1462426 - Installing with dnf produces error /var/tmp/rpm-tmp.jMe0EE: line 44 [: too many arguments
Installing with dnf produces error /var/tmp/rpm-tmp.jMe0EE: line 44 [: too ma...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: quagga (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Ruprich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-17 10:45 EDT by Quentin Armitage
Modified: 2017-11-28 18:48 EST (History)
3 users (show)

See Also:
Fixed In Version: quagga-1.2.2-1.fc26 quagga-1.2.2-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-28 11:21:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Armitage 2017-06-17 10:45:33 EDT
Description of problem:
See summary

Version-Release number of selected component (if applicable):
quagga-1.2.1-1.fc26.x86_64

How reproducible:
Always

Steps to Reproduce:
1. dnf install quagga
2.
3.

Actual results:
Reports error: /var/tmp/rpm-tmp.jMe0EE: line 44 [: too many arguments

Expected results:
No errors

Additional info:
The test 'if [ -f /usr/share/info/quagga.inf* ]' is failing since there are three files which match the wildcard. This test is used in both the postinstall and postuninstall scriptlets.

Perhaps the following would be better:
ls %{_infodir}/%{name}.inf* 2>/dev/null
if [ $? -eq 0 ]; then
Comment 1 Michal Ruprich 2017-11-08 06:54:59 EST
Thanks Quentin, I am planning a rebase of quagga in Fedora soon so I'll be fixing this along with that.
Comment 2 Fedora Update System 2017-11-14 07:59:28 EST
quagga-1.2.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7d25605e98
Comment 3 Fedora Update System 2017-11-14 07:59:48 EST
quagga-1.2.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-df3032c978
Comment 4 Fedora Update System 2017-11-14 11:46:18 EST
quagga-1.2.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7d25605e98
Comment 5 Fedora Update System 2017-11-14 12:13:56 EST
quagga-1.2.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-df3032c978
Comment 6 Fedora Update System 2017-11-28 11:21:11 EST
quagga-1.2.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2017-11-28 18:48:12 EST
quagga-1.2.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.