Bug 1462463 - Black screen after unlocking automatic locked session
Summary: Black screen after unlocking automatic locked session
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: light-locker   
(Show other bugs)
Version: 26
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-17 21:14 UTC by Heiko Adams
Modified: 2017-06-22 13:36 UTC (History)
6 users (show)

Fixed In Version: light-locker-1.7.0-4.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-22 13:36:21 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github https://github.com/the-cavalry light-locker issues 98 None None None 2017-06-18 17:48 UTC
Red Hat Bugzilla 1421671 None None None Never

Internal Trackers: 1421671

Description Heiko Adams 2017-06-17 21:14:42 UTC
Description of problem:
After unlocking an automatic locked session the screen is black and the only way to get the desktop back is to reboot the system.

Version-Release number of selected component (if applicable):
$ rpm -q light-locker lightdm
light-locker-1.7.0-3.fc26.x86_64
lightdm-1.22.0-1.fc26.x86_64

How reproducible:
allways

Steps to Reproduce:
1. Let lightdm automatic lock the active session
2. Try to unlock the session
3.

Actual results:
The screen gets black and stays at that status

Expected results:
The session should be unlocked and continue working should be possible

Additional info:

Comment 1 Raphael Groner 2017-06-18 11:11:07 UTC
Hi Heiko,
thanks for your report. This issue is reproducible for me. As I didn't actively use light-locker in recent times, I did not recognize this severe bug.
We'll take a deeper look why lightdm can't unlock the session, maybe the lightdm maintainers can help, temporarily reassign to get them into boat.

Comment 2 Heiko Adams 2017-06-18 11:29:13 UTC
As a workaround disabling automatic session-locking helps

Comment 3 Heiko Adams 2017-06-18 11:54:10 UTC
It seems session, which are manually locked with "dm-tool lock" are not affected by this.

Comment 4 leigh scott 2017-06-18 11:56:41 UTC
(In reply to Raphael Groner from comment #1)

> We'll take a deeper look why lightdm can't unlock the session, maybe the
> lightdm maintainers can help, temporarily reassign to get them into boat.

Surely it's light-locker job to unlock?

Comment 5 Raphael Groner 2017-06-18 12:22:48 UTC
(In reply to Heiko Adams from comment #3)
> It seems session, which are manually locked with "dm-tool lock" are not
> affected by this.

But an explicit 'light-locker-command --lock' from terminal locks the session forever. Hit the unlock button in lightdm screen, then the screen changes to black.

Comment 6 Raphael Groner 2017-06-18 13:02:05 UTC
It seemed for me in first run to be a bug with a combination of the (pre-release) version 1.7.0 of light-locker (as we currently ship in all Fedora versions, beginning with F24 upwards) and lightdm with whatever version.

This issue is -not- reproducible for me with light-locker 1.6.0 as we've in EPEL7 as well as -not- with F24:
lightdm-1.10.6-4.fc24.x86_64
light-locker-1.7.0-2.fc24.x86_64

The bug seems to be more related to lightdm-1.22.0-1.fc26. Reassigning.

Comment 7 Raphael Groner 2017-06-18 13:11:48 UTC
 Rex Dieter 2017-05-19 15:35:53 CEST

As lightdm maintainer, I object to this update, I typically only support LTS lightdm releases (unless I missed something and 1.22.0 is in fact a LTS-supported release).

https://bugzilla.redhat.com/show_bug.cgi?id=1421671#c5

Comment 8 leigh scott 2017-06-18 16:37:13 UTC
(In reply to Raphael Groner from comment #7)
>  Rex Dieter 2017-05-19 15:35:53 CEST
> 
> As lightdm maintainer, I object to this update, I typically only support LTS
> lightdm releases (unless I missed something and 1.22.0 is in fact a
> LTS-supported release).
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1421671#c5

And you point?

lightdm works fine it's light-locker that is broken so fix it instead of posting irrelevant shit.

Comment 9 leigh scott 2017-06-18 16:40:59 UTC
(In reply to Raphael Groner from comment #5)
> (In reply to Heiko Adams from comment #3)
> > It seems session, which are manually locked with "dm-tool lock" are not
> > affected by this.
> 
> But an explicit 'light-locker-command --lock' from terminal locks the
> session forever. 

Lightdm has no gui, what you see is light-locker unlock button

> Hit the unlock button in lightdm screen, then the screen
> changes to black.

Comment 10 Heiko Adams 2017-06-18 16:59:22 UTC
So how to solve this issue?

Comment 11 leigh scott 2017-06-18 17:18:36 UTC
(In reply to Heiko Adams from comment #10)
> So how to solve this issue?

Get the light-locker maintainer to fix it.

Maybe you have something similar to

https://github.com/the-cavalry/light-locker/issues/76

Comment 12 Heiko Adams 2017-06-18 17:48:40 UTC
Okay, I filed a bugreport for this upsteam: https://github.com/the-cavalry/light-locker/issues/98

Comment 13 leigh scott 2017-06-18 18:05:04 UTC
(In reply to Raphael Groner from comment #7)
>  Rex Dieter 2017-05-19 15:35:53 CEST
> 
> As lightdm maintainer, I object to this update, I typically only support LTS
> lightdm releases (unless I missed something and 1.22.0 is in fact a
> LTS-supported release).
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1421671#c5

Looking at light-locker f26 build log

https://kojipkgs.fedoraproject.org//packages/light-locker/1.7.0/3.fc26/data/logs/x86_64/build.log


checking for XF86VidModeSetGammaRamp in -lXxf86vm... yes
checking for XF86MiscSetGrabKeysState in -lXxf86misc... no
checking for SYSTEMD... no
checking for more warnings... no
checking that generated files are newer than configure... done


        Maintainer mode:          yes
                    Platform:
                    ---------
        systemd:                  no
        ConsoleKit:               yes
        UPower:                   yes
                    Features:
                    ---------
        lock-after-screensaver:   yes

https://github.com/the-cavalry/light-locker/commit/97c2b936f9a5bbb91f3b26dbf899862bd38b8858

I suggest you try building with these configure options so it fails if it can't find systemd

%configure --enable-lock-on-suspend=on --with-systemd --without-console-kit --disable-silent-rules --with-gtk3

Comment 14 Heiko Adams 2017-06-18 18:25:11 UTC
I'm currently rebuilding the packaged with the suggested config parameters and will report back if that solves the issue

Comment 15 leigh scott 2017-06-18 18:35:43 UTC
(In reply to Heiko Adams from comment #14)
> I'm currently rebuilding the packaged with the suggested config parameters
> and will report back if that solves the issue

Try this rpm, it the latest git

https://leigh123linux.fedorapeople.org/pub/rpm/light-locker-1.7.0-4.fc26.x86_64.rpm

I tested in mate and it works as expected using slick-greeter

lightdm-1.22.0-1.fc26.x86_64
lightdm-gobject-1.22.0-1.fc26.x86_64
lightdm-gobject-devel-1.22.0-1.fc26.x86_64
lightdm-gtk-2.0.2-4.fc26.x86_64
lightdm-gtk-greeter-settings-1.2.0-6.fc26.noarch
lightdm-settings-1.1.0-1.fc26.noarch
light-locker-1.7.0-3.fc26.x86_64
slick-greeter-1.0.7-2.fc26.x86_64


I see light-locker uses the lightdm greeter to unlock, as it works with current lightdm I reassigning it back to light-locker

Comment 16 leigh scott 2017-06-18 18:42:18 UTC
(In reply to leigh scott from comment #15)

> light-locker-1.7.0-3.fc26.x86_64

I don't bump version for locally tested rpm's so dnf updates it when the fix is released

Comment 17 Heiko Adams 2017-06-18 18:57:45 UTC
Okay, that did it :-)

Comment 18 Raphael Groner 2017-06-18 19:04:22 UTC
You can not expect people to use slick-greeter only. As it now works for you with light-locker in latest version (1.7.0), I doubt a bug in this component. Really, this is a bug in lightdm with the default greeter. Reassigning again.

Comment 19 leigh scott 2017-06-18 19:07:19 UTC
(In reply to Raphael Groner from comment #18)
> You can not expect people to use slick-greeter only. As it now works for you
> with light-locker in latest version (1.7.0), I doubt a bug in this
> component. Really, this is a bug in lightdm with the default greeter.
> Reassigning again.

Get real and fix your bug!!!!!!!!

Comment 20 leigh scott 2017-06-18 19:08:59 UTC
(In reply to Heiko Adams from comment #17)
> Okay, that did it :-)

Which greeter do you use as the light-locker maintainer (if you can call him that)  doesn't get it :-)

Comment 21 Heiko Adams 2017-06-18 19:17:08 UTC
For the records: I'm using lightdm with gtk-greeter

Comment 22 leigh scott 2017-06-18 19:19:43 UTC
(In reply to Heiko Adams from comment #21)
> For the records: I'm using lightdm with gtk-greeter

Thank you for confirming it isn't a lightdm or greeter issue.

Comment 23 Raphael Groner 2017-06-18 19:22:34 UTC
(In reply to leigh scott from comment #13)
…
> https://github.com/the-cavalry/light-locker/commit/
> 97c2b936f9a5bbb91f3b26dbf899862bd38b8858
> 
> I suggest you try building with these configure options so it fails if it
> can't find systemd
> 
> %configure --enable-lock-on-suspend=on --with-systemd --without-console-kit
> --disable-silent-rules --with-gtk3

Please open a new bug about an inclusion request for the mentioned systemd patch from upstream (11 days old). I fail actually to see a direct relation to the hereby discussed black screen issue.

@Heiko What version of systemd do you use without suffering from a black screen?

Comment 24 leigh scott 2017-06-18 19:27:18 UTC
(In reply to Raphael Groner from comment #18)
> You can not expect people to use slick-greeter only. As it now works for you
> with light-locker in latest version (1.7.0), I doubt a bug in this
> component. Really, this is a bug in lightdm with the default greeter.
> Reassigning again.

The reporter uses lightdm-gtk so what is your lame excuse now? are you going to persist in you false assumptions?
Or are you going to fix the light-locker systemd issue, I recommend you use the latest gitshot!

Now stop wasting my valuable time, I have plenty of other stuff to update/fix already!

Comment 25 leigh scott 2017-06-18 19:28:16 UTC
(In reply to Raphael Groner from comment #23)
> (In reply to leigh scott from comment #13)
> …
> > https://github.com/the-cavalry/light-locker/commit/
> > 97c2b936f9a5bbb91f3b26dbf899862bd38b8858
> > 
> > I suggest you try building with these configure options so it fails if it
> > can't find systemd
> > 
> > %configure --enable-lock-on-suspend=on --with-systemd --without-console-kit
> > --disable-silent-rules --with-gtk3
> 
> Please open a new bug about an inclusion request for the mentioned systemd
> patch from upstream (11 days old). I fail actually to see a direct relation
> to the hereby discussed black screen issue.

Screw you!, you already wasted enough of my time.

Comment 26 Heiko Adams 2017-06-18 19:31:06 UTC
(In reply to Raphael Groner from comment #23)
> @Heiko What version of systemd do you use without suffering from a black
> screen?

$ rpm -q systemd
systemd-233-4.fc26.x86_64

Comment 27 Raphael Groner 2017-06-18 19:40:40 UTC
I can't still understand why it works in F24 (light-locker 1.7.0 and lightdm 1.10.6) and also in EPEL7 (light-locker 1.6.0 and lightdm 1.10.6 as well).
See comment #6.

Comment 28 Heiko Adams 2017-06-18 19:43:03 UTC
Maybe checking the build-logs and systemd versions for that releases helps.

Comment 29 Raphael Groner 2017-06-18 20:08:16 UTC
Leigh, you seem to not have read everything at light-locker f26 build log:
https://kojipkgs.fedoraproject.org//packages/light-locker/1.7.0/3.fc26/data/logs/x86_64/build.log

> configure: WARNING: unrecognized options: --with-gtk3

I am especially wondering if we built against the right API with the last F26 mass rebuild that produced the current package version in F26. How to validate we really use GTK3? Upstream uses different calls to clear the screen depending on what GTK version detected in configure:
https://github.com/the-cavalry/light-locker/blob/master/src/gs-window-x11.c#L129

Comment 30 leigh scott 2017-06-18 21:20:32 UTC
(In reply to Raphael Groner from comment #29)
> Leigh, you seem to not have read everything at light-locker f26 build log:
> https://kojipkgs.fedoraproject.org//packages/light-locker/1.7.0/3.fc26/data/
> logs/x86_64/build.log
> 
> > configure: WARNING: unrecognized options: --with-gtk3

That warning has nothing to do with the issue, you added it

http://pkgs.fedoraproject.org/cgit/rpms/light-locker.git/commit/?id=e2f1a382f4e7ce99dbdee13e9a0843388d27a179

I will spell the issue issue in caveman style so you understand

systemd/logind is used to track the session, if light-locker doesn't use it how is the greeter meant to know what to unlock (that's my guess, I didn't look that deep).
When testing the f26 official build I noticed a consolekit warning, add that to the missing systemd support.
The only real difference in git is the improved systemd support, the rest looks like improved debug support.
Given that git has no gtk changes and functions correctly you are wasting more time trying to gloss over the real issue.


> 
> I am especially wondering if we built against the right API with the last
> F26 mass rebuild that produced the current package version in F26. How to
> validate we really use GTK3? Upstream uses different calls to clear the
> screen depending on what GTK version detected in configure:
> https://github.com/the-cavalry/light-locker/blob/master/src/gs-window-x11.
> c#L129

Comment 31 Björn 'besser82' Esser 2017-06-18 21:49:17 UTC
This IS definetly an issue with light-locker.  Fixed build is on it's way…

@raphgro:  Shut up!  I fixed your fsckin' package for you!

Comment 32 Raphael Groner 2017-06-18 22:00:34 UTC
Björn, thanks for the fixes!

Comment 33 Fedora Update System 2017-06-18 22:06:32 UTC
light-locker-1.7.0-4.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2f00dce9a0

Comment 34 Fedora Update System 2017-06-19 19:23:48 UTC
light-locker-1.7.0-4.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2f00dce9a0

Comment 35 Fedora Update System 2017-06-22 13:36:21 UTC
light-locker-1.7.0-4.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.