Bug 1462469 - Kernel kernel-4.11.5-300.fc26.x86_64 Does Not Properly Refresh Screen or Adjust Resolution on QXL
Kernel kernel-4.11.5-300.fc26.x86_64 Does Not Properly Refresh Screen or Adju...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
26
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-17 18:58 EDT by Joseph D. Wagner
Modified: 2018-03-13 20:02 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1450725
Environment:
Last Closed: 2018-03-13 20:02:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
oops-2017-05-21-12:55:46-730-0 (16.72 KB, application/x-gzip)
2017-06-20 13:47 EDT, Joseph D. Wagner
no flags Details
oops-2017-06-03-16:25:15-717-0.tar.gz (16.12 KB, application/x-gzip)
2017-06-20 13:47 EDT, Joseph D. Wagner
no flags Details

  None (edit)
Description Joseph D. Wagner 2017-06-17 18:58:32 EDT
+++ This bug was initially created as a clone of Bug #1450725 +++

Description of problem:
RHGB screen flickers 3 times, then freezes. Unable to escape.

Version-Release number of selected component (if applicable):
4.12.0-0.rc0.git7.1.fc27.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Boot that kernel version.

Actual results:
Freeze on RHGB screen. No error. Not responsive to any keys. Unable to drop to shell.

Expected results:
Should boot normally.

Additional info:
4.12.0-0.rc0.git2.1.fc27.x86_64 worked fine.

Removing rhgb from kernel parameters gets the system to boot, but it cuts off the right and bottom third of the screen.

Tried enforcing=0. No effect.

--- Additional comment from Joseph D. Wagner on 2017-05-15 14:10:47 EDT ---

This problem persists on 4.12.0-0.rc0.git9.1.fc27.x86_64

--- Additional comment from Joseph D. Wagner on 2017-05-21 18:47:11 EDT ---

This appears to be a problem with the QXL driver.  When I set the VM to use VGA, it boots normally.

This problem persists on 4.12.0-0.rc1.git4.1.fc27.x86_64.

--- Additional comment from Joseph D. Wagner on 2017-06-02 13:57:00 EDT ---

It's improving, but it still isn't fixed. Now on kernel-4.12.0-0.rc3.git0.2.fc27.x86_64. Successfully boots without crashing. However, the screen doesn't refresh the windows or buttons until I move the mouse over the button/window/widget/etc. Also, I can't change/adjust the screen resolution.

Works ok on VGA, but not QXL. If I boot into the previous kernel version kernel-4.12.0-0.rc0.git2.1.fc27.x86_64, then QXL works fine; the only difference being the version of kernel select at boot time.

--- Additional comment from Joseph D. Wagner on 2017-06-03 19:29:27 EDT ---

More information. I got one crash report that cited:
drivers/gpu/drm/ttm/ttm_bo_util.c:589 [qxl]

--- Additional comment from Joseph D. Wagner on 2017-06-16 14:04:08 EDT ---

Problem still exists on 4.12.0-0.rc5.git0.1.fc27.x86_64.
Comment 1 Joseph D. Wagner 2017-06-17 19:00:21 EDT
On Fedora 26 Beta, I cannot get the system to boot using the QXL driver on kernel-4.11.5-300.fc26.x86_64, but the VGA driver works ok. When booting into previous kernel-4.11.0-2.fc26.x86_64, both the QXL and VGA drivers work fine.
Comment 2 Joseph D. Wagner 2017-06-17 19:01:53 EDT
Can you reproduce this? If so, I request that this be a Beta blocker, because it prevents the system from booting.
Comment 3 Joseph D. Wagner 2017-06-18 14:26:55 EDT
It appears the bug is not in drivers/gpu/drm/ttm/ttm_bo_util.c:589, but rather this section of code is being called by the function with the bug in it. Here is the relevant context from the ttm_bo_util.c file:

int ttm_bo_kmap(struct ttm_buffer_object *bo,
		unsigned long start_page, unsigned long num_pages,
		struct ttm_bo_kmap_obj *map)
{
	struct ttm_mem_type_manager *man =
		&bo->bdev->man[bo->mem.mem_type];
	unsigned long offset, size;
	int ret;

	BUG_ON(!list_empty(&bo->swap));
Comment 4 Laura Abbott 2017-06-19 13:58:04 EDT
Can you attach the kernel backtrace you saw?
Comment 5 Joseph D. Wagner 2017-06-20 13:47 EDT
Created attachment 1289763 [details]
oops-2017-05-21-12:55:46-730-0
Comment 6 Joseph D. Wagner 2017-06-20 13:47 EDT
Created attachment 1289764 [details]
oops-2017-06-03-16:25:15-717-0.tar.gz
Comment 7 Alexis Jeandet 2017-06-27 16:07:17 EDT
Hello,

I don't know if this helps I think I see the same problem with 
-kernel-4.11.5-300.fc26.x86_64
-kernel-4.11.6-301.fc26.x86_64

While kernel-4.11.4-300.fc26.x86_64 boots ok.

here is a log when it fails:
https://ao.lpp.polytechnique.fr/s/GU7jKwRy3idPG44
Comment 8 Joseph D. Wagner 2017-06-29 00:48:44 EDT
After upgrading to the latest RPMS, I can no longer reproduce the problem in any kernel version on Fedora 26 Beta. As far as I can tell, whatever was triggering it was fixed.

FYI, I can still reproduce the problem in the 4.12.x series in rawhide.
Comment 9 Laura Abbott 2018-02-27 22:38:12 EST
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.
Comment 10 Joseph D. Wagner 2018-03-13 19:27:48 EDT
I believe this only applied to f26 when it was rawhide.
Comment 11 Laura Abbott 2018-03-13 20:02:09 EDT
Thanks for confirming. I'm going to go ahead and close the bug.

Note You need to log in before you can comment on or make changes to this bug.