Bug 1462481 - After a stack failure, the underlying deployment still stuck in 'IN_PROGRESS' state
After a stack failure, the underlying deployment still stuck in 'IN_PROGRESS'...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
medium Severity low
: rc
: 12.0 (Pike)
Assigned To: Rabi Mishra
Ronnie Rasouli
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-17 21:48 EDT by cshastri
Modified: 2017-12-13 16:32 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-heat-9.0.1-0.20170830131248.2b94474.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:32:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1585815 None None None 2017-06-20 11:11 EDT
OpenStack gerrit 484741 None None None 2017-09-01 08:25 EDT

  None (edit)
Description cshastri 2017-06-17 21:48:56 EDT
Description of problem:

After a stack failure, the underlying deployment still stuck in 'IN_PROGRESS' state.

Outputs:

~~~
[stack@instack ~]$ heat stack-list
WARNING (shell) "heat stack-list" is deprecated, please use "openstack stack list" instead
+--------------------------------------+------------+---------------+----------------------+--------------+
| id                                   | stack_name | stack_status  | creation_time        | updated_time |
+--------------------------------------+------------+---------------+----------------------+--------------+
| cf09ae55-e783-4c49-a4da-0ca02abc8897 | overcloud  | CREATE_FAILED | 2017-06-17T03:26:46Z | None         |
+--------------------------------------+------------+---------------+----------------------+--------------+

[stack@instack ~]$ heat resource-list overcloud | grep -v COMPLETE
WARNING (shell) "heat resource-list" is deprecated, please use "openstack stack resource list" instead
+-------------------------------------------+----------------------------------------------+-------------------------------------------------+-----------------+----------------------+
| resource_name                             | physical_resource_id                         | resource_type                                   | resource_status | updated_time         |
+-------------------------------------------+----------------------------------------------+-------------------------------------------------+-----------------+----------------------+
| Controller                                | 340ad3cb-caf3-492a-b709-55f4f2edfbc2         | OS::Heat::ResourceGroup                         | CREATE_FAILED   | 2017-06-17T03:26:46Z |
+-------------------------------------------+----------------------------------------------+-------------------------------------------------+-----------------+----------------------+

[stack@instack ~]$ heat resource-list 340ad3cb-caf3-492a-b709-55f4f2edfbc2 | grep -v COMPLETE
WARNING (shell) "heat resource-list" is deprecated, please use "openstack stack resource list" instead
+---------------+--------------------------------------+-------------------------+-----------------+----------------------+
| resource_name | physical_resource_id                 | resource_type           | resource_status | updated_time         |
+---------------+--------------------------------------+-------------------------+-----------------+----------------------+
| 0             | f44d0b45-9754-4a8e-a44b-2cc6a0a90aa4 | OS::TripleO::Controller | CREATE_FAILED   | 2017-06-17T03:27:44Z |
| 1             | 319d05d8-cf6f-4057-b7b4-7d2889098bac | OS::TripleO::Controller | CREATE_FAILED   | 2017-06-17T03:27:44Z |
| 2             | 50062735-4a27-4a89-94aa-871289b0434d | OS::TripleO::Controller | CREATE_FAILED   | 2017-06-17T03:27:44Z |
+---------------+--------------------------------------+-------------------------+-----------------+----------------------+

[stack@instack ~]$ heat resource-list f44d0b45-9754-4a8e-a44b-2cc6a0a90aa4 | grep -v COMPLETE
WARNING (shell) "heat resource-list" is deprecated, please use "openstack stack resource list" instead
+--------------------------+--------------------------------------+-------------------------------------------------+-----------------+----------------------+
| resource_name            | physical_resource_id                 | resource_type                                   | resource_status | updated_time         |
+--------------------------+--------------------------------------+-------------------------------------------------+-----------------+----------------------+
| NetworkDeployment        | d17c1774-0631-4cc8-b458-5617908942f8 | OS::TripleO::SoftwareDeployment                 | CREATE_FAILED   | 2017-06-17T03:27:47Z |
| UpdateDeployment         | c66479e9-39cd-4845-8dc1-ebde60ba4e3e | OS::Heat::SoftwareDeployment                    | CREATE_FAILED   | 2017-06-17T03:27:48Z |
+--------------------------+--------------------------------------+-------------------------------------------------+-----------------+----------------------+

[stack@instack ~]$ heat deployment-show d17c1774-0631-4cc8-b458-5617908942f8 
WARNING (shell) "heat deployment-show" is deprecated, please use "openstack software deployment show" instead
{
  "status": "IN_PROGRESS", 
  "server_id": "678cbbb2-3f49-4cd9-880e-fd096f3ec0f5", 
  "config_id": "1addf38a-f2bb-4610-b754-a56b31b0e2c5", 
  "output_values": null, 
  "creation_time": "2017-06-17T03:30:17Z", 
  "input_values": {
    "interface_name": "nic1", 
    "bridge_name": "br-ex"
  }, 
  "action": "CREATE", 
  "status_reason": "Deploy data available", 
  "id": "d17c1774-0631-4cc8-b458-5617908942f8"
}
~~~

I think this behavior occurs if the stack creation times out. 

Version-Release number of selected component (if applicable):
Red Hat OpenStack Platform 10

How reproducible:
Always

Steps to Reproduce:
1. After the stack creation times out, get the output of underlying resources 'deployment-show'

Actual results:
Deployment still stuck in 'IN_PROGRESS' state.

Expected results:
Deployment should be in 'FAILED' state stating the reason in 'status_reason'.
Comment 2 Zane Bitter 2017-06-20 11:11:59 EDT
Known issue upstream.
Comment 6 Thierry Vignaud 2017-09-01 08:28:02 EDT
Setting to latest build as it holds the fix
Comment 9 Ronnie Rasouli 2017-11-15 10:23:40 EST
verified by heat_integrationtests.functional.test_software_config passed
Comment 12 errata-xmlrpc 2017-12-13 16:32:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.