Bug 1462509 - LBaaS tests does not run on DFG-network-neutron-lbaas-10_director-rhel-7.3-virthost jobs
LBaaS tests does not run on DFG-network-neutron-lbaas-10_director-rhel-7.3-vi...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron-lbaas (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
high Severity high
: z4
: 10.0 (Newton)
Assigned To: Arie Bregman
Toni Freger
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-18 05:19 EDT by Eran Kuris
Modified: 2017-09-06 13:17 EDT (History)
12 users (show)

See Also:
Fixed In Version: openstack-neutron-lbaas-9.2.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-06 13:17:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 475193 None None None 2017-06-19 05:37 EDT

  None (edit)
Description Eran Kuris 2017-06-18 05:19:16 EDT
Description of problem:
LBaaS tests does not run on our CI jobs 
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/DFG/view/network/view/neutron-lbaas/
according to whitelist / blacklist it  should run 

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Run rhos10 CI job,
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Chandan Kumar 2017-06-19 05:36:16 EDT
As per the investigation, In neutron-lbaas OSP 10 branch, there is no 'neutron_lbaas/tests/tempest/plugin.py' file.it is a requirement for the tempest plugin.Apart from that we need to define an entry point in setup.cfg
something like that:
tempest.test_plugins =
    neutron_lbaas = neutron_lbaas.tests.tempest.plugin:NeutronLbaasTempestPlugin []
Tempest looks for "tempest.test_plugins" entrypoint in order to discover tempest plugin, if it is found it will list the plugin. The plugin.py file knows where the tempest tests related to specific project lives.

All the above things like : neither tempest_plugin entrypoint [https://github.com/openstack/neutron-lbaas/blob/stable/newton/setup.cfg#L33] and nor plugin.py file [https://github.com/openstack/neutron-lbaas/tree/stable/newton/neutron_lbaas/tests/tempest] found in stable/newton branch. That's why tempest has no clue whether there are tempest tests or not in neutron-lbaas in stable/newton or RHOS-10 branch.

So we cannnot run the neutron lbass tempest tests directly using tempest.

In order to fix the above issue, I have backported a patch review for the same: https://review.openstack.org/#/c/475193/1 which provides proper tempest plugin for neutron-lbass in newton.

Since it is not a tempest bug, so changing the component to neutron-lbaas.
Comment 4 Eran Kuris 2017-08-13 08:04:27 EDT
fix verified :
openstack-neutron-lbaas-9.2.1-2.el7ost.noarch
Comment 8 errata-xmlrpc 2017-09-06 13:17:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2663

Note You need to log in before you can comment on or make changes to this bug.