Bug 146251 - Boot process hangs at CPUSPEED step on x86_64
Boot process hangs at CPUSPEED step on x86_64
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jarod Wilson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 09:23 EST by Ryan
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 17:13:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan 2005-01-26 09:23:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041220 Firefox/1.0 Fedora/1.0-6.centos4.2

Description of problem:
The process cpuspeed causes the boot process to halt at this step on
the x86_64 version.  Forcing a hard boot is the only way to end the
boot process.  Boot process will not advance beyond this point.  This
also appears in Fedora Core, Version 3 for x86_64 also.  Hare is
listed below.

DFI LanParty UT 250GB
nForce 3 chipset
AMD 64 3200+
80 GB Maxtor IDE drive

Version-Release number of selected component (if applicable):
n/a

How reproducible:
Always

Steps to Reproduce:
1.  Install either RHEL 4.0 Beta2 or FC3 for x86_64
2.  Attempt to boot either OS
3.  OS will lock on cpuspeed and will not proceed.
    

Actual Results:  Boot process hung and would not advance on step
"Starting CPUSPEED".

Expected Results:  It should have booted completely in the OS,
providing a stable OS for use.

Additional info:
Comment 1 Suzanne Hillman 2005-02-01 11:03:58 EST
Have you checked if this still happens with the rhel4 release candidate?
Comment 2 Ryan 2005-02-01 12:25:28 EST
Where do I acquire the RC?  All I've been able to get a hold of is RHEL 4 
beta2.  Thanks
Comment 3 Suzanne Hillman 2005-02-02 14:53:26 EST
Just determined that we are not able to reproduce this in-house on one of our
own beta2 x86_64 boxes, so I'm suspecting something specific to your hardware.

Did this machine work with previous releases?
Comment 4 Michal Szymanski 2005-05-19 17:36:17 EDT
I have not been able to boot FC3 x86_64 SMP kernels (none of the available,
2.6.9 and higher) until I disabled 'cpuspeed' services. Contrary to the original
post, there was no proble to boot the system into uP kernel. That is how I was
able to disable cpuspeed. The hangs were at random places after 'cpuspeed' but I
have never got to the end of the boot process.

Also, the machine was resetting right after GRUB initial screen when trying to
boot SMP kernel after a reboot from uP session (w/o hard reset or power off/on).
The reason seems to be that the machine's CPU(s) were left in low-frequency
(1GHz instead of nominal 2.4GHz). The BIOS screen shows 1.0GHz until a hard reset.

My machine is dual-Opteron 250, Tyan K8W S2875 MoBo. Fedora Core 3 x86_64.

Michal.
Comment 5 Suzanne Hillman 2005-05-20 09:07:52 EDT
Michal - as your comment is specific to FC, and does not appear to relate to
RHEL at all, would you please open a new bug for Fedora Core for your problem?
Comment 6 Michal Szymanski 2005-05-23 06:09:13 EDT
I have just opened it for FC3, bug #158523
Comment 8 Jarod Wilson 2007-02-12 16:46:07 EST
Can this issue be reproduced with the latest RHEL4 bits?
Comment 9 Jarod Wilson 2007-06-15 17:13:55 EDT
No activity on this bug in 2 years, works fine on a ton of hardware we have
in-house. Closing WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.