Bug 146254 - Config channel creation errors
Config channel creation errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn370
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Bowman
Max Spevack
http://rhn.webdev.redhat.com/network/...
:
Depends On: 146885 146886
Blocks: 145821
  Show dependency treegraph
 
Reported: 2005-01-26 09:48 EST by Michael Bowman
Modified: 2007-04-18 13:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 12:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Bowman 2005-01-26 09:48:22 EST
Description of problem:
Channel Administrator gets error when trying to create a new config
channel.

Steps to Reproduce:
1. Create a new corporate account / grant entitlements
2. Create a new user and give new user Channel Admin role
3. Login as new user and try to create a config channel
  
Actual results:
Error page.

Expected results:
I'm assuming this should work or that the user shouldn't see the
'create new config channel' link in the first place. Also, even though
the user gets an error page, the config channel is created. The new
user can't see it though if they browse back to the page.

Additional info:
I have already created a few users to reproduce this one since we
thought it may have been caused by the java code at first.
Org Admin: ssprockets2/dog8code
Channel Admin: gjetson002/dog8code
Comment 1 Bret McMillan 2005-01-26 12:44:44 EST
Whenever you generate an unexpected 500 page, be sure to include w/
the bug the traceback that was generated.  In this case, I believe its:

Form variables:
  ccid => 4468

User Information:
  User mbowman17 (id 3916069, org_id 4313995)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  RHN::Exception: DBD::Oracle::st execute failed: ORA-01403: no data found
ORA-06512: at "RHN.RHN_CONFIG_CHANNEL", line 69
ORA-06512: at line 2 (DBD NO_DATA: OCIStmtExecute) [for Statement "BEGIN
  :ret := rhn_config_channel.get_user_chan_access(:p1, :p2);
END;" with ParamValues: :ret=undef, :p1='4468', :p2='3916069']
  RHN::DB /var/cvs/rhn/web/modules/rhn/RHN/DB.pm 219
RHN::Exception::DB::throw
  RHN::DB::db /var/cvs/rhn/web/modules/rhn/RHN/DB.pm 475
RHN::DB::handle_error
  RHN::DB::User /var/cvs/rhn/web/modules/rhn/RHN/DB/User.pm 1338
RHN::DB::db::call_function
  RHN::DB::User /var/cvs/rhn/web/modules/rhn/RHN/DB/User.pm 1773
RHN::DB::User::verify_permission_function_helper
  RHN::Cleansers /var/www/lib/RHN/Cleansers.pm 171
RHN::DB::User::verify_config_channel_access
  RHN::Cleansers /var/www/lib/RHN/Cleansers.pm 140
RHN::Cleansers::check_param
  PXT::Request /var/cvs/rhn/web/modules/pxt/PXT/Request.pm 233
RHN::Cleansers::cleanse
  PXT::ApacheHandler /var/cvs/rhn/web/modules/pxt/PXT/ApacheHandler.pm
439 PXT::Request::cleanse_params
  PXT::ApacheHandler /var/cvs/rhn/web/modules/pxt/PXT/ApacheHandler.pm
439 (eval)
  PXT::ApacheAuth /var/cvs/rhn/web/modules/pxt/PXT/ApacheAuth.pm 23
PXT::ApacheHandler::initialize_pxt
  main /dev/null 0 PXT::ApacheAuth::handler
  main /dev/null 0 (eval)
Comment 2 Michael Bowman 2005-02-01 16:11:33 EST
You must have the config_admin acl to create config channels
correctly, however links to create config channels show up to everybody.

Also, anybody is allowed to delete config channels... this seems wrong
to me, but it could be that I just don't know everything about how
these work yet...

Comment 3 Michael Bowman 2005-02-24 12:27:12 EST
Added acl to toolbar to only show create/delete links if a config admin.
Comment 4 Fanny Augustin 2005-03-07 18:07:54 EST
Please provide a test plan. Thanks!
Comment 5 Michael Bowman 2005-03-08 08:36:50 EST
This bug got rolled into the changes bretm and I made to the config channel ui
(146886). Originally, this bug was filed because when a normal user tried to
create a config channel, the ui allowed him to, but the db threw exceptions
since the user didn't have the proper permissions. 

This is now not an issue since there is no way for a normal user to try and
create a config channel. 

I suppose a test plan would be to log in as a normal user (not an org or config
admin) and go to the channels tab. You should *not* see a "manage config
channels" link in the left-hand navigation. You should not be able to get to a
form that allows you to create a config channel.
Comment 6 Max Spevack 2005-03-15 16:52:50 EST
PROD_READY

1.  Logging in as a normal user with no admin rights, you see no links
for manage config channels

2.  Granting that user Config Admin rights and logging back in
displays the config channel management links.
Comment 7 Todd Warner 2005-04-08 12:10:29 EDT
mass move: PROD_READY --> CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.