Bug 1462544 - Editing from sftp / sshfs mounts done in nautilus not working
Editing from sftp / sshfs mounts done in nautilus not working
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: geany (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-18 13:24 EDT by Ariel
Modified: 2017-07-22 10:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-22 10:24:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github 893 None None None 2017-06-18 13:24 EDT

  None (edit)
Description Ariel 2017-06-18 13:24:40 EDT
Description of problem:

opening a file mount via sftp in nautilus: geany shows the file as if it had no content at all, and if "save" is invoked it will overwrite the original file, all the contents are lost, people can easily lose code due to this problem - even worse: this can haven with auto-save as well.

Reported upstream, not sure if this is due to upstream or related to Fedora packaging, GIO or other



https://github.com/geany/geany/issues/893




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. in nautilus, mount any folder via sftp such as: sftp://yourname@yourIP/home/somename
2.browse the mount and find a python script, then Open it with Geany


Actual results:
Geany opens the file but shows no content at all. If you press Save by mistake, you will lose all your code.


Expected results:
Geany should show file contents


Additional info:
Comment 1 Dominic Hopf 2017-07-22 10:24:43 EDT
As this is reported to upstream with https://github.com/geany/geany/issues/893, there is no need to have this issue opened here. When the upstream bug gets fixed, the next update for Fedora will automatically included the fix.

Note You need to log in before you can comment on or make changes to this bug.