Bug 1462560 - Calibre 3.0 will not start - Python Import Exception
Calibre 3.0 will not start - Python Import Exception
Status: CLOSED DUPLICATE of bug 1462534
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-18 18:12 EDT by Jason Bowen
Modified: 2017-06-18 18:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-18 18:17:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Bowen 2017-06-18 18:12:14 EDT
Description of problem: Calibre 3.0 will not start. I uninstalled (`dnf erase calibre`) and reinstalled (`dnf install calibre`) and the issue persists.


Version-Release number of selected component (if applicable): calibre-3.0.0-1.fc27


How reproducible: Very


Steps to Reproduce:
1. Install Calibre 3.0
2. Attempt to run
3. Watch it fail

Additional info:

Startup error from Calibre:
---------------------------------------------------------------------------
calibre, version 3.0.0
ERROR: Startup error: There was an error during calibre startup. Parts of calibre may not function. Click Show details to learn more.

Traceback (most recent call last):
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 291, in initialize_db_stage2
    self.start_gui(db)
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 226, in start_gui
    main = self.main = Main(self.opts, gui_debug=self.gui_debug)
  File "/usr/lib64/calibre/calibre/gui2/ui.py", line 159, in __init__
    ac = self.init_iaction(action)
  File "/usr/lib64/calibre/calibre/gui2/ui.py", line 173, in init_iaction
    ac = action.load_actual_plugin(self)
  File "/usr/lib64/calibre/calibre/customize/__init__.py", line 614, in load_actual_plugin
    ac = getattr(importlib.import_module(mod), cls)(gui,
  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in import_module
    __import__(name)
  File "/usr/lib64/calibre/calibre/gui2/actions/catalog.py", line 12, in <module>
    from calibre.gui2.tools import generate_catalog
  File "/usr/lib64/calibre/calibre/gui2/tools.py", line 15, in <module>
    from calibre.gui2.convert.single import NoSupportedInputFormats
  File "/usr/lib64/calibre/calibre/gui2/convert/single.py", line 19, in <module>
    from calibre.gui2.convert.search_and_replace import SearchAndReplaceWidget
  File "/usr/lib64/calibre/calibre/gui2/convert/search_and_replace.py", line 11, in <module>
    from calibre.gui2.convert.search_and_replace_ui import Ui_Form
  File "/usr/lib64/calibre/calibre/gui2/convert/search_and_replace_ui.py", line 155, in <module>
    from regex_builder import RegexEdit
  File "/usr/lib64/calibre/calibre/gui2/convert/regex_builder.py", line 18, in <module>
    from calibre.ebooks.conversion.search_replace import compile_regular_expression
  File "/usr/lib64/calibre/calibre/ebooks/conversion/search_replace.py", line 6, in <module>
    import regex
ImportError: No module named regex
---------------------------------------------------------------------------
Comment 1 Kevin Fenzi 2017-06-18 18:17:06 EDT

*** This bug has been marked as a duplicate of bug 1462534 ***

Note You need to log in before you can comment on or make changes to this bug.