Bug 1462592 - RFE: Mellanox hardware offload support for openvswitch
RFE: Mellanox hardware offload support for openvswitch
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: Upstream M2
: 13.0 (Queens)
Assigned To: Stephen Finucane
Joe H. Rahme
: FutureFeature, OtherQA, Triaged
: 1468329 (view as bug list)
Depends On: 1467356 1383792 1467354 1467359 1469552 1470100
Blocks: 1419948 1474827
  Show dependency treegraph
 
Reported: 2017-06-18 22:57 EDT by Moshe Levi
Modified: 2018-06-27 09:33 EDT (History)
21 users (show)

See Also:
Fixed In Version: openstack-nova-17.0.0-0.20180123163703.27eadbc.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-27 09:31:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 398265 None master: MERGED nova: hardware offload support for openvswitch (I3f38954bc5cf7b1690182dc8af45078eea275aa4) 2018-02-07 08:53 EST
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 09:33 EDT

  None (edit)
Description Moshe Levi 2017-06-18 22:57:04 EDT
In Kernel 4.8 we introduced Traffic Control (TC see [1]) hardware offloads
framework for SR-IOV VFs which allows us to configure the NIC [2].
Subsequent OVS patches [3] allow us to use the TC framework
to offload OVS datapath rules. The feature is merged in ovs upstream. 

To allow the support in openstack we need the following changes:
os-vif - https://review.openstack.org/#/c/460278/
This patch adds plug/unplug when using ovs vif 'OVS_ACCELERATION'. The
plug method will lookup the VF representor and connect it to 'br-int',
while the unplug method will remove the VF representor from 'br-int'.

nova- https://review.openstack.org/#/c/398265/
This patch add support for  VIF_TYPE_OVS_ACCELERATION

neutron patches - https://review.openstack.org/#/c/275616/ & https://review.openstack.org/#/c/452530/
This patch allow OVS mech driver to bind direct (SR-IOV) port.
This will allow to offload the OVS flows using tc to the SR-IOV NIC
and gain accelerate OVS.

The current support is for ovs mechanism driver we will extend the support to other mechanism drivers such odl and ovn.


[1] https://linux.die.net/man/8/tc
[2] http://netdevconf.org/1.2/papers/efraim-gerlitz-sriov-ovs-final.pdf
[3] https://mail.openvswitch.org/pipermail/ovs-dev/2017-April/330606.html
Comment 2 Slava Shwartsman 2017-07-03 09:46:58 EDT
This BZ depends on:
Bug 1467356 - [Mellanox Pike FEAT] openstack-neutron: Add support for OVS HW offload
Bug 1467354 - [Mellanox Pike FEAT] openstack-nova: add support for VIF_TYPE_OVS_ACCELERATION
Bug 1467220 - [Mellanox Pike FEAT] openvswitch: update package
Bug 1467359 - [Mellanox Pike FEAT] python-os-vif: update package
Comment 6 Lee Yarwood 2017-12-07 12:22:42 EST
*** Bug 1468329 has been marked as a duplicate of this bug. ***
Comment 9 Jon Schlueter 2018-06-22 12:20:33 EDT
The content for this fix is included in OSP 13 RC which is available on the Red Hat OpenStack Platform beta channels currently.  Any efforts to verify that these bugs have been fixed would be appreciated.
Comment 10 Moshe Levi 2018-06-25 08:09:09 EDT
Do you mean to check ovs-offload works with OSP 13?
What exact bugs are you referring
Comment 12 errata-xmlrpc 2018-06-27 09:31:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086

Note You need to log in before you can comment on or make changes to this bug.