Bug 146261 - Download for big (>2GB) files gives error Value too large for defined data type
Download for big (>2GB) files gives error Value too large for defined data type
Status: CLOSED DUPLICATE of bug 109332
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 10:21 EST by Juergen Vigna
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Vigna 2005-01-26 10:21:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When trying to access a ISO image (DVD of FC3) over the httpd server
there is an error in the error_log file as following:

[Wed Jan 26 10:20:55 2005] [error] [client x.x.x.x] (75)Value too
large for defined data type: access to
/yam/fc3-i386/iso/FC3-i386-DVD.iso failed
This is on a FC3 systems with *all* updates online.

Moreover it will not "index" that file if I just access the directory!


Version-Release number of selected component (if applicable):
httpd-2.0.52-3.1

How reproducible:
Always

Steps to Reproduce:
1. Put a file > 2GB in a directory accessible by httpd and activate
the index option
2. Try to visualize that directory (URL) on your browser
3. Try to force to download the ISO file giving the whole URL to it
    

Actual Results:  The file could not be downloaded I got this output in
the browser:

> Forbidden
> 
> You don't have permission to access 
> /yam/fc3-i386/iso/FC3-i386-DVD.iso on this server.
> 
> Additionally, a 403 Forbidden error was encountered while trying to
> use an ErrorDocument to handle the request.
> Apache/2.0.52 (Fedora) Server at rhupd Port 80

and this in the error_log file:

[Wed Jan 26 16:18:28 2005] [error] [client x.x.x.x] (75)Value too
large for defined data type: access to
/yam/fc3-i386/iso/FC3-i386-DVD.iso failed

Expected Results:  To be able to download the file.

Additional info:
Comment 1 Joe Orton 2005-01-26 10:24:05 EST

*** This bug has been marked as a duplicate of 109332 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.