Bug 1462629 - [New UI] - Improve and align the whole 'Network Interfaces' dialog
[New UI] - Improve and align the whole 'Network Interfaces' dialog
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
x86_64 Linux
unspecified Severity high (vote)
: ovirt-4.2.0
: ---
Assigned To: Alexander Wels
Michael Burman
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 01:35 EDT by Michael Burman
Modified: 2017-12-24 05:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The Network Interfaces tab in the Compute > Host details view has been re-designed so that important NIC information is always visible and more details can be viewed by expanding the Expand/Collapse button of each network interface.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:57:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)
screenshots (110.67 KB, application/x-gzip)
2017-06-19 01:35 EDT, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78388 master MERGED webadmin: Re-design of HOST interfaces 2017-08-10 09:52 EDT

  None (edit)
Description Michael Burman 2017-06-19 01:35:38 EDT
Created attachment 1289014 [details]
screenshots

Description of problem:
[New UI] - Improve and align the whole 'Network Interfaces' dialog.

The new UI design now expose that the whole 'Network Interfaces' under 'Hosts' is completely non-aligned and doesn't look well.

The columns and the info are not synced and not aligned at all. attaching screenshot.

It should be improved as this is very confusing.

- Another thing is to finally allow the expand mechanism for the columns headers for this dialog(it is the only dialog which missing this mechanism).

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170618184152.gitb0f84a1.el7.centos

How reproducible:
100 

Steps to Reproduce:
1. Install latest 4.2 master
2. Go to 'Hosts' > 'Network Interfaces'
Comment 1 Red Hat Bugzilla Rules Engine 2017-06-19 21:45:49 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Alexander Wels 2017-06-20 08:02:33 EDT
Actually that isn't new, that been there since 3.1 or so (the code still has Itamar as most of the blame source). I am currently working on aligning the view with the VM network interfaces view.
Comment 3 Michael Burman 2017-06-20 08:09:58 EDT
(In reply to Alexander Wels from comment #2)
> Actually that isn't new, that been there since 3.1 or so (the code still has
> Itamar as most of the blame source). I am currently working on aligning the
> view with the VM network interfaces view.

Although it's not new, only now in the new UI design it's look broken and not aligned). Thanks
Comment 4 Michael Burman 2017-08-21 01:20:10 EDT
Verified on - 4.2.0-0.0.master.20170820180837.git59243e9.el7.centos
Comment 5 Sandro Bonazzola 2017-12-20 05:57:52 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.