Bug 146264 - bash (readline?) issue after command returned without LF
Summary: bash (readline?) issue after command returned without LF
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bash   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-26 15:48 UTC by Joe Orton
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 16:06:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2005-01-26 15:48:47 UTC
This bugs me occasionally.

jorton@trash:~$ rpm -q bash
bash-3.0-25.i386
jorton@trash:~$ echo -n foo
foojorton@trash:~$

OK so far; now type "bar" then hit Ctrl-a then Ctrl-e 

jorton@trash:~$ barbar

the line is redrawn from column 0 but is not cleared first.

bug or feature?

Comment 1 Tim Waugh 2005-01-26 16:06:08 UTC
Feature.  Bash either has to assume that it's starting on the first column
(leading to the behaviour you see), or make sure that it's starting on the first
column by emitting '\r' before the prompt.

In the latter case (which was the behaviour for a short while) you would not see
the output of the echo command at all, since it would be overwritten.


Note You need to log in before you can comment on or make changes to this bug.