Bug 1462640 - Defunct ceilometer-api will appear if workers is larger than 1
Defunct ceilometer-api will appear if workers is larger than 1
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Eoghan Glynn
Sasha Smolyak
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 02:31 EDT by Chen
Modified: 2017-06-20 10:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-20 10:26:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chen 2017-06-19 02:31:16 EDT
Description of problem:

Defunct ceilometer-api will appear if workers is larger than 1

Version-Release number of selected component (if applicable):

OSP8

openstack-ceilometer-*-5.0.5-1.el7ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. Install a packstack OSP8 environment
2. Increase api/workers from 1 to 10
3. openstack-service restart ceilometer
4. ceilometer meter-list
5. ps -ef|grep ceilometer 

Actual results:

You will find a defunct ceilometer-api process

Expected results:

No defunct process should exist

Additional info:
Comment 1 Julien Danjou 2017-06-19 09:40:06 EDT
As packstack is not supported, can you replicate this bug with OSP director?
Comment 2 Chen 2017-06-19 09:58:24 EDT
Hi Julien,

Actually my customer found this issue in a director based environment and packstack was used to reproduce the issue.

Best Regards,
Chen
Comment 3 Mehdi ABAAKOUK 2017-06-20 10:12:28 EDT
I have reproduced it, this is not a ceilometer issue but a python-werkzeug bug, it doesn't reap terminate processes. The upstream bug is https://github.com/pallets/werkzeug/pull/864.
Comment 4 Chen 2017-06-20 10:16:21 EDT
Hi Mehdi,

Thank you very much for your reply.

So according to the upstream bug, it seems that this is expected behaviour and it will not cause any big impact so this issue could safely be ignored am I correct ?

Best Regards,
Chen
Comment 5 Mehdi ABAAKOUK 2017-06-20 10:26:33 EDT
Exactly, Zombie processes don't impact the way Ceilometer works and can be ignored.

Upstream will not fix this issue, because python-werkzeug is supposed to be used only for development. Recent version of Ceilometer have move out of python-werkzeug and are no more impacted by this.

Note You need to log in before you can comment on or make changes to this bug.