This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1462641 - libosinfo should include the new version of rhel 7.4
libosinfo should include the new version of rhel 7.4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libosinfo (Show other bugs)
7.4
Unspecified Linux
high Severity medium
: rc
: ---
Assigned To: Felipe Borges
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 02:49 EDT by tingting zheng
Modified: 2017-08-01 18:54 EDT (History)
10 users (show)

See Also:
Fixed In Version: osinfo-db-20170423-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 18:54:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2017-06-19 02:49:52 EDT
Description of problem:
libosinfo should include the new version of rhel 7.4,isn't better to fix this bug on rhel7.4?

Version-Release number of selected component (if applicable):
libosinfo-1.0.0-1.el7.x86_64
virt-manager-1.4.1-7.el7.noarch
libvirt-3.2.0-10.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Launch virt-manager and Select "Network Install(HTTP,FTP or NFS)".
2. In Step2 of 5, input:http://download.eng.pek2.redhat.com/pub/rhel/rel-eng/RHEL-7.4-20170608.3/compose/Server/x86_64/os/,then check automatically detect version,it detects the version as rhel7.3.
3. Check "OS type" and "Version",there is no "rhel7.4".

Actual results:
As description.

Expected results:
libosinfo should include the new version of rhel7.4.

Additional info:
Comment 2 Felipe Borges 2017-06-26 10:19:48 EDT
I have proposed an upstream patch at https://www.redhat.com/archives/libosinfo/2017-June/msg00013.html

For osinfo-db we are not patching but rebasing at every change. This is mostly because the database is not "built" but imported by the osinfo-db-import tool.
Comment 8 errata-xmlrpc 2017-08-01 18:54:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2113

Note You need to log in before you can comment on or make changes to this bug.