Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 146266 - The -rv command switch appears to be the -r switch
The -rv command switch appears to be the -r switch
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vim (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 11:09 EST by Joshua Weage
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 08:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Weage 2005-01-26 11:09:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When attempting to use the vim -rv switch, I get:

E305: No swap file found for LICENSE

which is what the -r switch should produce.  So it looks like -rv is
being treated as the -r command switch.



Version-Release number of selected component (if applicable):
vim-enhanced-6.3.046-0.30E.1

How reproducible:
Always

Steps to Reproduce:
1.  Execute 'vim -rv file'
2.
3.
    

Actual Results:  E305

Expected Results:  Open the editor in reverse video mode.

Additional info:
Comment 1 Karsten Hopp 2005-01-27 09:26:03 EST
-rv or -reverse is only supported with gvim. Check the output of
'vim --help' and 'gvim --help'
Comment 2 Joshua Weage 2005-02-03 08:01:19 EST
I still think there is a bug here.

Up until the most recent relese of vim, 'vim -rv' changed the syntax
color scheme to the dark background version.  That's what my version
of vim 6.3p15 does.

With the new release, vim is interpreting '-rv' and other combinations
of -r. as '-r', which isn't correct.
Comment 3 Karsten Hopp 2005-09-08 08:31:43 EDT
This looks very much like intended behaviour to me. grep for -rv in the sources
and you'll see that it is used only in the X11 stuff. And I've looked through
the patches that have been applied between 6.3p15 and 6.3.046, there's nothing
which would cause the behaviour change you're describing.

Note You need to log in before you can comment on or make changes to this bug.