Bug 1462668 - /forcefsck on btrfs root does not repair filesystem
/forcefsck on btrfs root does not repair filesystem
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
25
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint-list
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 04:48 EDT by Bernhard Schuster
Modified: 2017-06-29 07:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-29 07:29:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Schuster 2017-06-19 04:48:07 EDT
Description of problem:

Broken btrfs root nodes

Version-Release number of selected component (if applicable):

btrfs-progs v4.6.1

NAME=Fedora
VERSION="25 (Workstation Edition)"
ID=fedora
VERSION_ID=25
PRETTY_NAME="Fedora 25 (Workstation Edition)"


How reproducible:

Always


Steps to Reproduce:
1. luks encrypted root
2.  do a lot of parallel btrfs subvolume / snapshot creation and deletion operations which triggers a btrfs bug to forget some nodes
3. reboot into rescue mode since normal boot fails
4. login into recovery shell and `touch /forcefsck` to force check on reboot

Actual results:

No fixed root fs

Expected results:

Repaired root fs, i.e. a call to btrfs check --repair ${FS}

Additional info:
Comment 1 Harald Hoyer 2017-06-29 07:29:31 EDT
$ rpm -qf /usr/sbin/fsck.btrfs 
btrfs-progs-4.11-1.fc27.x86_64

Tell them to fix their fsck.btrfs

Note You need to log in before you can comment on or make changes to this bug.