Bug 1462677 - GNOME Web crashes when saving an image from discogs.com.
Summary: GNOME Web crashes when saving an image from discogs.com.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany
Version: 26
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Catanzaro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-19 09:13 UTC by Ryan Farmer
Modified: 2017-07-21 15:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-21 15:39:15 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 778653 None None None 2017-06-23 18:17:18 UTC

Description Ryan Farmer 2017-06-19 09:13:15 UTC
Description of problem:

GNOME Web crashes when saving an image from discogs.com.


Version-Release number of selected component (if applicable):

3.24.2

How reproducible:


Steps to Reproduce:
1. USING Gnome Web, go to https://www.discogs.com/Metallica-Greatest-Hits-Part-I/release/1976261

2. Click on the album cover image to make it bigger then right-click and Save Image As.

3. Gnome Web crashes, but ABRT won't upload an error report because Web crashed in a way that didn't produce a proper core dump.

Comment 1 Michael Catanzaro 2017-06-23 18:17:19 UTC
Thanks for reporting. This is probably GNOME #778653. Too late for 3.24.3, but I'll try to fix it for 3.24.4 since it looks simple.

Comment 2 Michael Catanzaro 2017-06-23 18:18:05 UTC
(In reply to Michael Catanzaro from comment #1)
> Thanks for reporting. This is probably GNOME #778653. Too late for 3.24.3,
> but I'll try to fix it for 3.24.4 since it looks simple.

Oh wait, 3.24.3 doesn't exist yet. Maybe I'll do that soon, then. :P

Comment 3 Michael Catanzaro 2017-07-02 17:12:26 UTC
This will be fixed in 3.24.3, which I'll probably release in about two weeks.

Comment 4 Ryan Farmer 2017-07-21 07:19:42 UTC
Version 3.24.3 doesn't really fix the problem. The browser no longer crashes, but now it fails to download the image with "Error downloading: Service Unavailable.".

Comment 5 Michael Catanzaro 2017-07-21 15:39:15 UTC
Yeah, that's surely a WebKit bug though. If you want you can report it on WebKit Bugzilla.


Note You need to log in before you can comment on or make changes to this bug.