Bug 1462777 - Plan export fails
Plan export fails
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
high Severity high
: Upstream M2
: 12.0 (Pike)
Assigned To: Toure Dunnon
Alexander Chuzhoy
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 09:58 EDT by Jason E. Rist
Modified: 2018-02-05 14:07 EST (History)
8 users (show)

See Also:
Fixed In Version: openstack-tripleo-common-7.1.1-0.20170616124957.93d87e0.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:32:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1698811 None None None 2017-06-19 09:58 EDT
OpenStack gerrit 475383 None None None 2017-06-19 10:23 EDT
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-15 20:43:25 EST

  None (edit)
Description Jason E. Rist 2017-06-19 09:58:40 EDT
Cloned from launchpad bug 1698811.

Description:

The plan export command fails both from command line and GUI.

The reason seems to be a missing argument to the get_object_client() method:
https://github.com/openstack/tripleo-common/blob/master/tripleo_common/actions/plan.py#L258

Specification URL (additional information):

https://bugs.launchpad.net/tripleo/+bug/1698811
Comment 1 Jason E. Rist 2017-06-19 10:23:38 EDT
Fix upstream: https://review.openstack.org/#/c/475383/
Comment 2 Jason E. Rist 2017-06-19 17:41:08 EDT
Merged
Comment 6 Alexander Chuzhoy 2017-06-21 10:15:03 EDT
openstack-tripleo-common-7.1.1-0.20170612015630.414f94b.el7ost.noarch

(undercloud) [stack@undercloud-0 ~]$ openstack overcloud plan list
+-----------+
| Plan Name |
+-----------+
| overcloud |
+-----------+
(undercloud) [stack@undercloud-0 ~]$ openstack overcloud plan  export overcloud
Exporting plan overcloud...
Started Mistral Workflow tripleo.plan_management.v1.export_deployment_plan. Execution ID: 66a19a9b-f14d-482f-b6ce-e6ad950c6622
{u'body': {u'exception': u'(pymysql.err.OperationalError) (2006, "MySQL server has gone away (error(32, \'Broken pipe\'))") [SQL: u\'INSERT INTO `Queues` (project, name, metadata) VALUES (%(project)s, %(name)s, %(metadata)s)\'] [parameters: {\'project\': u\'ee49e60494e54bbea47685ee2d7da186\', \'name\': u\'35b24c00-fd03-41a5-a852-8bdefd280108\', \'metadata\': bytearray(b\'{}\')}]', u'error': u'Unexpected error.'}, u'headers': {u'status': 500}, u'request': {u'action': u'queue_create', u'body': {u'queue_name': u'35b24c00-fd03-41a5-a852-8bdefd280108'}, u'api': u'v2', u'headers': {u'Client-ID': u'7a4a42a9-9e54-4add-a0a1-34192aec3ad4', u'X-Project-ID': u'ee49e60494e54bbea47685ee2d7da186'}}}
(undercloud) [stack@undercloud-0 ~]$ echo $?
1
(undercloud) [stack@undercloud-0 ~]$
Comment 7 Alexander Chuzhoy 2017-06-21 10:29:31 EDT
The bits didn't land yet
Comment 12 Alexander Chuzhoy 2017-06-22 16:40:16 EDT
FailedQA

Environment:
openstack-tripleo-common-7.1.1-0.20170616124957.93d87e0.el7ost.noarch

(undercloud) [stack@undercloud-0 ~]$ openstack overcloud plan list
+-----------+
| Plan Name |
+-----------+
| overcloud |
+-----------+
(undercloud) [stack@undercloud-0 ~]$ openstack overcloud plan  export overcloud
Exporting plan overcloud...
Started Mistral Workflow tripleo.plan_management.v1.export_deployment_plan. Execution ID: 610959d6-3c96-4be4-bf3f-902e977a70ce


Timed out waiting for messages from Execution (ID: 610959d6-3c96-4be4-bf3f-902e977a70ce, State: ERROR). The Workflow errored and no messages were received.

(undercloud) [stack@undercloud-0 ~]$
Comment 13 Jason E. Rist 2017-06-27 09:32:59 EDT
I just tried this and it works fine for me using
openstack-tripleo-common-7.1.1-0.20170623115707.4ba7d56.el7.centos.noarch
Comment 14 Thierry Vignaud 2017-06-29 05:09:01 EDT
I confirm we've the change
Comment 16 Alexander Chuzhoy 2017-06-29 09:23:05 EDT
Verified:
Environment:
openstack-tripleo-common-7.1.1-0.20170623115707.4ba7d56.el7ost.noarch

(undercloud) [stack@undercloud-0 ~]$ openstack overcloud plan list
+-----------+
| Plan Name |
+-----------+
| overcloud |
+-----------+
(undercloud) [stack@undercloud-0 ~]$ openstack overcloud plan export overcloud
Exporting plan overcloud...
Started Mistral Workflow tripleo.plan_management.v1.export_deployment_plan. Execution ID: 9cc0a5a5-11ad-4da6-9c49-16f79f9b1803
http://192.168.24.1:8080/v1/AUTH_d40585db50b24af0a03e298810d4ff29/plan-exports/overcloud.tar.gz?temp_url_sig=3c0cc0a37bd49aaa5c42865184eaed039e698af9&temp_url_expires=1498744970
(undercloud) [stack@undercloud-0 ~]$ echo $?
0
(undercloud) [stack@undercloud-0 ~]$ ls -l|grep overcloud.tar

-rw-rw-r--.  1 stack stack     390948 Jun 29 09:02 overcloud.tar.gz
Comment 19 errata-xmlrpc 2017-12-13 16:32:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.