Bug 1462796 - Tap-as-a-Service on OSP - Due date / status?
Tap-as-a-Service on OSP - Due date / status?
Status: CLOSED DUPLICATE of bug 1411311
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Nir Yechiel
Toni Freger
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 10:43 EDT by David Peacock
Modified: 2017-07-17 09:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 17:13:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Peacock 2017-06-19 10:43:07 EDT
Description of problem:

We have a customer requesting the status / ETA of TaaS on RHOSP.

They provided me with the following description of their desired use case.

Please let me know if you need any questions answered or any more detail from the customer.

"""
For the NFV infrastructure  we are requiring tapping for a number of use-cases:

Permanent capturing use-cases:
- Some Legal Intercept solutions being used on the legacy environment are relying on capture traffic on specific points permanently to a closed LI platform which allows law enforcement to do the necessary tracking (which under local law requires the ISP to be unaware on who or what is being tracked). Migrating towards a NFV platform the same functionality should be maintained including potentially for the traffic between to VM's on the same host.
- A number of Customer Services tools have been procured/developed that based on (mostly signalling) traffic analysis to provide easy troubleshooting up to the CS agent in the call center. These tools are using traffic captures with physical taps on the legacy environment. The goal is to preserve such feature parity and tooling continuity between the NFV environment and the legacy during the lengthy migration path towards  NFV. 
- For certain traffic flows the Security Operations Center (SOC) is using traffic base-lining tools in an attempt to identify anomalous traffic patterns. These flows can reside on the different parts of the NFV infrastructure. 

Ad-hoc capturing use-cases:
- The internal Security Operations Center (SOC) is desiring to be able to very selectively subject certain traffic flows to deep inspection based on Indicators of Compromise (IOC) on either systems, application or traffic behaviours.
- For troubleshooting purposes many application teams require the capability to capture traffic from the NFV infrastructure.

"""
Comment 1 David Peacock 2017-06-26 08:06:53 EDT
Hey there,

Please let me know the status of this, and if you need any more information or details from the customer.

Thank you!

David :-)
Comment 2 David Peacock 2017-07-13 16:18:11 EDT
Ping?
Comment 3 Assaf Muller 2017-07-13 17:13:29 EDT

*** This bug has been marked as a duplicate of bug 1411311 ***
Comment 4 Assaf Muller 2017-07-13 17:15:00 EDT
The main tracker for TaaS is in [1]. TaaS has not been prioritized or targeted for any future release and does not have a due date. If you can please add customer tickets or account names to [1] that would help when prioritizing TaaS in the future.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1411311
Comment 5 David Peacock 2017-07-17 09:08:42 EDT
Thank you Assaf; I'll pass along this to the customer.

Our customer that prompted me to raise this BZ is Belgacom.

Note You need to log in before you can comment on or make changes to this bug.