Bug 1462798 - DellSc: Cinder Volume migration using retype fails
DellSc: Cinder Volume migration using retype fails
Status: CLOSED DUPLICATE of bug 1293440
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Eric Harney
Avi Avraham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 10:47 EDT by Rajini Karthik
Modified: 2017-06-28 09:14 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 09:14:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rajini Karthik 2017-06-19 10:47:15 EDT
Description of problem:
•	The usecase is customer wants to migrating volumes from their old Dell Storage center (which was on loan) to another storage center which they have purchased.
•	They are currently using OSP8 ( Openstack Solution Platform8 aka Liberty). With OSP10 release, this is two releases behind
•	 We have recommended this option to 
Migrate the volume to backend2 using the ‘cinder retype’ with the migration policy on demand feature
•	They have started testing the cinder volume migration using retype snd encountered errors with volume attached to instances
o	Jamie from redhat has tested and found that it works without errors in OSP10
o	The volume driver that performs this in the generic one and should work. Nothing is specific to Storage Center


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Eric Harney 2017-06-21 09:08:54 EDT
Are there log files from this failure?

Do we know what fixed this in OSP10?
Comment 2 Rajini Karthik 2017-06-23 10:59:25 EDT
I'm not able to install devstack-liberty or OSP8 to reproduce this. Jamie from redhat has the logs. I will assign this to Jamie to upload the logs
Comment 3 Sean Cohen 2017-06-28 09:14:24 EDT
(In reply to Rajini Ram from comment #0)


Hello Rajini
The Migrating volumes between different storage backends or different storage clusters while the volume is in use in Cinder is not yet supported and currently planned for OSP13 tracked in bug 1293440.

I advise to perform it not attached at in these releases.
Comment 4 Sean Cohen 2017-06-28 09:14:57 EDT

*** This bug has been marked as a duplicate of bug 1293440 ***

Note You need to log in before you can comment on or make changes to this bug.