Bug 1462825 - Anconda bug reporting dialog is missing important log files & full traceback file
Anconda bug reporting dialog is missing important log files & full traceback ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
26
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Kolman
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F26FinalBlocker
  Show dependency treegraph
 
Reported: 2017-06-19 11:58 EDT by Martin Kolman
Modified: 2017-07-06 18:51 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-26.21.11-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 18:51:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kolman 2017-06-19 11:58:43 EDT
Description of problem:
The bug reporting dialog in Anaconda is not including important log files, such as the full Anaconda traceback dump, anaconda.log, storage.log, program.log. etc.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. start a F26 installation
2. perform https://fedoraproject.org/wiki/QA:Testcase_Anaconda_save_traceback_to_bugzilla
3. notice that the dialog where users can review what files will be uploaded to Bugzilla does not show any of the important Aanconda log files & the full traceback dump file

Actual results:
The full traceback file & important Anaconda log files are missing.

Expected results:
Full traceback file & important Anaconda log files are visible in the dialog.

Additional info:
The log files are present in /tmp as expected, including the anaconda-tb-* traceback dump file generated by python-meh.

As the Bugzilla upload dialog is provided by libreport it is possible this is caused by libreport changing how it includes log files in bugreports, so it is no longer picking up the Anaconda provided files.
Comment 1 Fedora Blocker Bugs Application 2017-06-19 12:02:02 EDT
Proposed as a Blocker for 26-final by Fedora user m4rtink using the blocker tracking app because:

 Violation of the "Installer - Failure reporting" criterium:
https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria#Failure_reporting

"The installer must be able to report failures to Bugzilla, with appropriate information included."

Anaconda log files & the full traceback are certainly appropriate and indispensable information for successfully debugging of installer issues.
Comment 2 Adam Williamson 2017-06-26 20:42:10 EDT
Discussed at 2017-06-26 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-06-26/f26-blocker-review.2017-06-26-16.03.html . Accepted as a blocker, as a violation of the criterion cited in #c1: we all agreed that this bug resulted in 'appropriate information' not being included in the report.
Comment 3 Adam Williamson 2017-06-28 18:17:47 EDT
CCing Matej Habrnal, who seems to be dealing with libreport lately. Folks, this is an F26 Final blocker and we're in the Final freeze; someone needs to figure out what's going on here and fix it. I did try taking a look myself, but it's not something super obvious I could spot right away.

Martin, do you have any idea when this started happening? We could probably figure it out by just looking at all anaconda abrt reports for the last few months and spotting when the files stopped showing up, but if you happen to know, it'd save us the work...
Comment 4 Adam Williamson 2017-06-28 18:20:54 EDT
Looking at the upstream libreport changelog, this change for 2.9.1 sounds possibly significant:

"Enhance the Bugzilla reporter to include only essential packaging details to make Bugzilla bug reports easier to comprehend."

I'm not sure what commits it relates to, yet.
Comment 5 Adam Williamson 2017-06-28 18:25:35 EDT
Sorry, that change was in 2.9.0, which hit Rawhide (fc26 at the time) in December 2016.
Comment 6 Martin Kolman 2017-06-29 12:53:59 EDT
PR: https://github.com/rhinstaller/anaconda/pull/1118
Comment 7 Fedora Update System 2017-06-30 07:25:33 EDT
anaconda-26.21.11-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-88f80a61da
Comment 8 Fedora Update System 2017-06-30 16:26:32 EDT
anaconda-26.21.11-1.fc26, blivet-gui-2.1.5-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-88f80a61da
Comment 9 Adam Williamson 2017-06-30 19:24:30 EDT
Verified the fix, see https://bugzilla.redhat.com/show_bug.cgi?id=1466965 .
Comment 10 Fedora Update System 2017-07-06 18:51:18 EDT
anaconda-26.21.11-1.fc26, blivet-gui-2.1.5-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.