Bug 146285 - undefined reference to `__ctype_tolower'
undefined reference to `__ctype_tolower'
Status: CLOSED DUPLICATE of bug 91290
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 13:27 EST by Arnaud LAHAYE
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 13:40:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaud LAHAYE 2005-01-26 13:27:18 EST
Hi,

When trying to compile C program i have :

cc -I/opt/sybase-11.9.2/include demonfax.c /opt/sybase-
11.9.2/lib/libsybdb.a -lm -o demonfax_p
/opt/sybase-11.9.2/lib/libsybdb.a(dbcursut.o)(.text+0xbb): In 
function `db__crs_search_phrase':
: undefined reference to `__ctype_tolower'
/opt/sybase-11.9.2/lib/libsybdb.a(dbcursut.o)(.text+0x110): In 
function `db__crs_search_phrase':
: undefined reference to `__ctype_tolower'
/opt/sybase-11.9.2/lib/libsybdb.a(intslist.o)(.text+0x17e): In 
function `intl__strblist':
: undefined reference to `__ctype_b'
/opt/sybase-11.9.2/lib/libsybdb.a(intnent.o)(.text+0xbf): In function 
`intl_nextentry':
: undefined reference to `__ctype_b'
/opt/sybase-11.9.2/lib/libsybdb.a(intnent.o)(.text+0x113): In 
function `intl_nextentry':
: undefined reference to `__ctype_b'
/opt/sybase-11.9.2/lib/libsybdb.a(intnent.o)(.text+0x1b6): In 
function `intl_nextentry':
: undefined reference to `__ctype_b'
/opt/sybase-11.9.2/lib/libsybdb.a(intnval.o)(.text+0x429): In 
function `intl_nextvalue':
: undefined reference to `__ctype_b'
/opt/sybase-11.9.2/lib/libsybdb.a(intnval.o)(.text+0x453): more 
undefined references to `__ctype_b' follow
collect2: ld returned 1 exit status
make: *** [demonfax_p] Error 1

This work fine with RedHat 7.3 Version
Here my complete glibc RPM package installation

glibc-kernheaders-2.4-8.34.1
glibc-2.3.2-95.30
glibc-headers-2.3.2-95.30
glibc-devel-2.3.2-95.30
compat-glibc-7.x-2.2.4.32.6
glibc-utils-2.3.2-95.30
glibc-profile-2.3.2-95.30
glibc-common-2.3.2-95.30

The same bug is report on
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=91290 

Orther related link
http://www.sybase.com/detail/printthis/1%2C6907%2C1029622%2C00.html


Please, find a solution, i must migrate a critical application for 
february

Thx.
Comment 1 Jakub Jelinek 2005-01-26 13:40:25 EST
The first bugreport has quite a good summary, so I don't think it is necessary
to repeat it here.
Just use
gcc296 -I /usr/lib/i386-redhat-linux7/include -B /usr/lib/i386-redhat-linux7/lib/
instead of
gcc or cc to compile and link the application against the old SyBASE library.
Binary compatibility is maintained only for programs and shared libraries,
not for object files and ar libraries of object files.

*** This bug has been marked as a duplicate of 91290 ***

Note You need to log in before you can comment on or make changes to this bug.