Bug 1462928 - initial-setup displays "Validating connection" instead of "Error during registration" in a box "Subscription Manager"
initial-setup displays "Validating connection" instead of "Error during regis...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.4
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Kevin Howell
John Sefler
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 13:40 EDT by Jan Stavel
Modified: 2018-04-10 05:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: subscription-manager-1.20.2-1
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 05:49:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Message "This system is currently not registered " is displayed (148.57 KB, image/png)
2017-11-09 23:06 EST, Shwetha Kallesh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Github candlepin/subscription-manager/pull/1675 None None None 2017-07-31 14:56 EDT
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 05:50 EDT

  None (edit)
Description Jan Stavel 2017-06-19 13:40:27 EDT
Description of problem:

Initial-setup should display "Error during registration" in a box "Subscription Manager" if I click "Done" instead of finishing a registration process.

Initial setup displays "Validating connection" instead of the error message.

Version-Release number of selected component (if applicable):

 Red Hat Enterprise Linux Workstation release 7.4 Beta (Maipo)
 ----------------------------     ----------------------------
 arch                             x86_64
 kernel version                   3.10.0-681.el7.x86_64
 ----------------------------     ----------------------------
 server type                      Red Hat Subscription Management
 subscription management server   2.0.33-1
 subscription management rules    5.23
 subscription-manager             1.19.20-1.el7
 python-rhsm                      1.19.9-1.el7
 ----------------------------     ----------------------------
 Product                          231.pem
 ----------------------------     ----------------------------
 Entitlement                      4852269804453163337.pem
 ----------------------------     ----------------------------


Steps to Reproduce:

Click on "Subscription Manager"
Click on a button "Next" (you see a form for password & login)
Click on a button "Done" instead of finishing the registration process.



Actual results:

A message "Validating connection" is displayed in a box "Subscription Manager"

Expected results:

You should see a message "Error during registration" in a box "Subscription Manager"

Additional info:
Comment 2 Martin Kolman 2017-06-20 04:54:38 EDT
The subscription manager screen and the subscription manager screen status are both provided by the Subscription manager addon, so reassigning to the Subscription Manager component.
Comment 4 Shwetha Kallesh 2017-11-09 23:06 EST
Created attachment 1350270 [details]
Message "This system is currently not registered " is displayed

Verified! The message "This system is currently not registered " is displayed when you click on done without registering 

[root@dhcp35-121 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription management rules: Unknown
Comment 5 Shwetha Kallesh 2017-11-09 23:07:45 EST
Please ignore the version in the comment 4:

[root@dhcp35-121 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription management rules: Unknown
subscription-manager: 1.20.5-1.el7
Comment 8 errata-xmlrpc 2018-04-10 05:49:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681

Note You need to log in before you can comment on or make changes to this bug.