Bug 1462928 - initial-setup displays "Validating connection" instead of "Error during registration" in a box "Subscription Manager"
Summary: initial-setup displays "Validating connection" instead of "Error during regis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-19 17:40 UTC by Jan Stavel
Modified: 2018-04-10 09:50 UTC (History)
3 users (show)

Fixed In Version: subscription-manager-1.20.2-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:49:52 UTC


Attachments (Terms of Use)
Message "This system is currently not registered " is displayed (148.57 KB, image/png)
2017-11-10 04:06 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:50:47 UTC
Github candlepin subscription-manager pull 1675 None None None 2017-07-31 18:56:45 UTC

Description Jan Stavel 2017-06-19 17:40:27 UTC
Description of problem:

Initial-setup should display "Error during registration" in a box "Subscription Manager" if I click "Done" instead of finishing a registration process.

Initial setup displays "Validating connection" instead of the error message.

Version-Release number of selected component (if applicable):

 Red Hat Enterprise Linux Workstation release 7.4 Beta (Maipo)
 ----------------------------     ----------------------------
 arch                             x86_64
 kernel version                   3.10.0-681.el7.x86_64
 ----------------------------     ----------------------------
 server type                      Red Hat Subscription Management
 subscription management server   2.0.33-1
 subscription management rules    5.23
 subscription-manager             1.19.20-1.el7
 python-rhsm                      1.19.9-1.el7
 ----------------------------     ----------------------------
 Product                          231.pem
 ----------------------------     ----------------------------
 Entitlement                      4852269804453163337.pem
 ----------------------------     ----------------------------


Steps to Reproduce:

Click on "Subscription Manager"
Click on a button "Next" (you see a form for password & login)
Click on a button "Done" instead of finishing the registration process.



Actual results:

A message "Validating connection" is displayed in a box "Subscription Manager"

Expected results:

You should see a message "Error during registration" in a box "Subscription Manager"

Additional info:

Comment 2 Martin Kolman 2017-06-20 08:54:38 UTC
The subscription manager screen and the subscription manager screen status are both provided by the Subscription manager addon, so reassigning to the Subscription Manager component.

Comment 4 Shwetha Kallesh 2017-11-10 04:06:49 UTC
Created attachment 1350270 [details]
Message "This system is currently not registered " is displayed

Verified! The message "This system is currently not registered " is displayed when you click on done without registering 

[root@dhcp35-121 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription management rules: Unknown

Comment 5 Shwetha Kallesh 2017-11-10 04:07:45 UTC
Please ignore the version in the comment 4:

[root@dhcp35-121 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription management rules: Unknown
subscription-manager: 1.20.5-1.el7

Comment 8 errata-xmlrpc 2018-04-10 09:49:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.