Bug 1462929 - Disallow RAID reshaping/take-over in a cluster or when LV is under a snapshot
Disallow RAID reshaping/take-over in a cluster or when LV is under a snapshot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Heinz Mauelshagen
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 13:40 EDT by Jonathan Earl Brassow
Modified: 2017-08-01 17:54 EDT (History)
10 users (show)

See Also:
Fixed In Version: lvm2-2.02.171-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 17:54:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2017-06-19 13:40:44 EDT
We will defer the reshaping/takeover capabilities in a cluster or while the RAID LV is under a snapshot until RHEL7.5.
Comment 3 Heinz Mauelshagen 2017-06-19 15:17:38 EDT
1439399: upstream commit f342e803ba3c32890a2b08736fa94bdd541d5e9c
 
1448116.
1441562,
1448123: upstream commit fb46175ce7550fd6c9f40e6d8eec337fc2693e80
Comment 6 Corey Marthaler 2017-06-21 19:21:56 EDT
Marking verified in the latest rpms. 

3.10.0-685.el7.x86_64
lvm2-2.02.171-6.el7    BUILT: Wed Jun 21 09:35:03 CDT 2017
lvm2-libs-2.02.171-6.el7    BUILT: Wed Jun 21 09:35:03 CDT 2017
lvm2-cluster-2.02.171-6.el7    BUILT: Wed Jun 21 09:35:03 CDT 2017
device-mapper-1.02.140-6.el7    BUILT: Wed Jun 21 09:35:03 CDT 2017
device-mapper-libs-1.02.140-6.el7    BUILT: Wed Jun 21 09:35:03 CDT 2017
device-mapper-event-1.02.140-6.el7    BUILT: Wed Jun 21 09:35:03 CDT 2017
device-mapper-event-libs-1.02.140-6.el7    BUILT: Wed Jun 21 09:35:03 CDT 2017
device-mapper-persistent-data-0.7.0-0.1.rc6.el7    BUILT: Mon Mar 27 10:15:46 CDT 2017



# Cluster

[root@harding-03 ~]# lvconvert --yes -R 1024.00k  --type raid6_n_6 centipede2/takeover
  Using default stripesize 64.00 KiB.
  Conversion of centipede2/takeover not supported in the cluster.
[root@harding-03 ~]# lvconvert --yes --stripes 5 centipede2/takeover
  Using default stripesize 64.00 KiB.
  Conversion of centipede2/takeover not supported in the cluster.


# Snapshot

[root@harding-03 ~]# lvconvert --yes -R 16384.00k  --type raid6_ra_6 centipede2/takeover
  Using default stripesize 64.00 KiB.
  Can't convert snapshot origin centipede2/takeover.
[root@harding-03 ~]# lvconvert --yes --stripes 5 centipede2/takeover
  Using default stripesize 64.00 KiB.
  Can't convert snapshot origin centipede2/takeover.
Comment 7 Heinz Mauelshagen 2017-06-22 16:17:28 EDT
For reference,
these are the related bzs this one avoids by disabling respectively:

bugzilla.redhat.com/1439399
bugzilla.redhat.com/1447812
bugzilla.redhat.com/1448116
bugzilla.redhat.com/1461526
Comment 8 errata-xmlrpc 2017-08-01 17:54:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2222

Note You need to log in before you can comment on or make changes to this bug.