Bug 1462952 - [3.5] Node lost connectivity to pod on another node (due to invalid ARP cache)
[3.5] Node lost connectivity to pod on another node (due to invalid ARP cache)
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking (Show other bugs)
3.4.1
Unspecified Linux
urgent Severity urgent
: ---
: 3.5.z
Assigned To: Ben Bennett
Meng Bo
: OpsBlocker
Depends On: 1451854 1462955
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 14:18 EDT by Ben Bennett
Modified: 2017-07-18 02:51 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When an IP address was re-used it would be generated with a random MAC address that would be different from the previous one. Consequence: Any node with an ARP cache that still held the old entry for the IP would not be able to communicate with the node. Fix: Generate the MAC address deterministically from the IP address. Result: A re-used IP address will always have the same MAC address, so the ARP cache can not be out of sync. So the traffic will flow.
Story Points: ---
Clone Of: 1451854
Environment:
Last Closed: 2017-07-11 06:47:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Origin (Github) 14685 None None None 2017-06-19 14:18 EDT
Github openshift/ose/pull/791 None None None 2017-06-19 14:33 EDT

  None (edit)
Comment 2 hongli 2017-06-22 22:19:04 EDT
verified in atomic-openshift-3.5.5.28-1.git.0.5eb85e0.el7.x86_64, the pod MAC address generation has been changed and no other issue found.

  3: eth0@if15: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 8951 qdisc noqueue state UP 
    link/ether 0a:58:0a:02:02:09 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet 10.2.2.9/23 scope global eth0
Comment 4 errata-xmlrpc 2017-07-11 06:47:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1640

Note You need to log in before you can comment on or make changes to this bug.